Unable to use the HDMI for output images...


After several mouth doing nothing related to… I’m trying to use the HDMI output of my 4000.

Unfortunatelly I can’t achieve to have success. :frowning:

I’ve checked the forun and I checked all I found that can give me problems.

I’ve the last version of graphics library: 1.1.0

The SAMD is up to date “bootloader is already the latest version”

When board lauch In one of my tv I can see the logo but fliking on the screen. And in the right up corner the green square. Even the TV recognice that the input is a DVI HDMI.

See here a video:

In the other TV I get ever black screen.

I cheked with a HDMI monitor without success.

Thanks in advance.

There few things what can cause this.

  • Poor clock generation
  • Too small LVDS drive strenght / bad cable
  • Card is restarting

For detecting card reset is easy. Just add led blink to setup section of sketch
For bad LVDS levels try better or shorter cable.

For bad clock I would use external oscillator but need to check what pin is clock network input for FPGA

It was also mentioned that the monitor/tv could draw significant current from the hdmi 5v output pin, and the usb port of a laptop might start limiting the current for the entire board, which could lead to all kinds of issues.

So it's worth trying to power the board from a charger, and not from usb port of a PC.
Note that the hdmi sketch waits for the terminal to be connected, so either remove the line waiting the serial port, or enter the bootloader with quick double tap on the button. It should output arduino logo on the hdmi.

I have similar problem. No output image through HDMI not even in boot loader mode.
Board and cables are brand new. I have tried the following:

  • boot loader recovery procedure
  • updating boot loader
  • updating libraries
  • double tapping reset
  • using 5V2A AC adapter
  • using usb 3.0 and opening serial monitor
  • commenting lines with serial communication
  • downgrading board version

I manage to get some image with green square in the top right corner multiple times
while running communication through HDMI developer board. Still never have I managed to get self-written sketches or test images onto the screen. Display I am using is acer g246hl.

I had a similar issue and went through 3 different monitors before I found one that works. I'm using an older HP Monitor going HDMI from the board to DVI on the monitor. This seemed to work. I tried with another with HDMI to RGB using a powered adapter and that did not work either.

I noticed on the monitor that is working it shows when switching between inputs that it recommends setting to 1680x1050 rather than the 640x480 the example is setting it to. Maybe adjusting the resolution in Vidor_GFX.h might help:
#define VIDOR_WIDTH 1680
#define VIDOR_HEIGHT 1050

Although, I did try this but it did not change the resolution so I might be missing something.

For that resolution there maybe llimitations with LVDS output duffer bandwith.

If I remeber right that resolution was set also in QSYS component as parameter for FBST IP. That IP is generating videostream with sync signal for DVI_OUT IP