Unable to view serial ouput on Arudino nano 33 ble sense using usb-ttl cable

Hi All,
I have flashed the zephyr project sample application on my Arudino nano 33 ble sense using the instructions provided in the zephyrproject page (Arduino Nano 33 BLE (Sense) — Zephyr Project Documentation). i have flashed via /dev/ttyACM0 over usb to usb-mini cable connecting my arudino to my laptop.
Once flashing is done, CDC_ACM port is lost and cannot be found either in dmesg or arudino IDE and hence i have connected usb-ttl cable by connecting only RX/RX pins from my board to my cable and running minicom with 115200 8N1 configuration.
I tried both the options still no luck.

  1. powering my arduino using the USB able and connecting only RX/TX pins on ttl cable.
  2. connecting all 4 pins on my usb-ttl cable to my arudino so that power and data available from ttl cable.
    Still i don't see any output on minicom.

So my question is,

  1. is my usage of usb-ttl cable is correct? if so, then any configurations that needed to be done
  2. how to enable CDC_ACM once my flashing is done so that i can avoid usb-ttl completely.

Thanks.

Probably not. Rx is the input pin, TX is the output pin. The devices cannot listen on the Tx pin nor talk on the Rx pin. you need to connect Rx to Tx. If this does not solve it post a schematic, not a frizzy thing.

Looking at the [schematic](https://content.arduino.cc/assets/NANO33BLE_V2.0_sch.pdf of the BLE sense), the serial pins are not used for communication with the PC; this is different from the classic Nano. So if you use e.g. a Serial.println, it will not go to the TX pin but to the USB. You will probably need Serial1.println; not sure what it is called on your board.

What does lsusb report when you connect the board?