Uninstall Arduino windows 10

Big problem: I am trying to update to newer version of Arduino but can't because the old version is only partly uninstalled and I can't find where the other files are hiding. Keep getting error message that version 1.66 will be deleted but it does not. I am using Widows 10 and can't navigate around it like earlier versions. anyone know how to do this?

Find if it is present in “programs and features” < Control panel. If present, try uninstalling it from there.

Make sure it's removed from programs and features listing.

Then to get rid of all the debris it leaves behind delete C:\Users(your username)\AppData\Local\Arduino15 (I think AppData is hidden by default)

Steps to access arduino's directory;

1) Get windows 10 full access with your user name 2) Go to C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.10.0_x86__mdqgnx93n4wtt 3) You will find full Arduino install with all subdirectories

I stop here because what I look for was to do direct shortcut to Arduino program

I suppose if you wish to unistall it, first is to erase all this directory and then clean the regedit.

Hint; I found this directory looking first the regedit

@EGCicala

That might be the way if you installed from the AppStore. But you did not make that clear. And as I have never used the AppStore, I can't say for sure but I'm quite sure there should be an uninstall option for applications installed that way; it's too risky, for those that not know, to edit the registry.

For normal install (as done by sane people ;)), I would follow DrAzzy's advise.

What's up with that Windows App crap! :angry: I also made the mistake to install the App. Didn't know Apps are different to normal software. Now I can't run Arduino as Admin by default, because that option is greyed out when I right-click the link (Arduino just a few minutes ago decided that it wants to throw errors when not run as admin on the same exact Marlin code that worked fine for the last weeks). Far worse: I can't seem to uninstall that App. What is Microsoft doing? Ads in the start menu, ads on the effing login screen for the microsoft store, now Apps you can't uninstall?! Oh an add to that my desktop and laptop randomly booting at night cyring for updates while I try to sleep! :angry: Sorry for the little rant...guess I need to do it like EGCicala proposed. Thanks for that.

Some help for uninstalls attached.

Bob.

CLEAN UP BEFORE INSTALLING ANOTHER COPY OF THE IDE OR ARDUINO CREATE.pdf (347 KB)

I just got bitten by this as well. Turns out the fix is simple.

Select the Start button, then select Settings > Apps > Apps & features.. Select the app you want to remove, and then select Uninstall.

Is the portable option still available for the newer versions of the IDE. That always worked really well for me in both Windows 7 and Windows 10. The IDE isn't actually installed at all, and can be uninstalled by just deleting the folder (after saving your Portable folder, of course.)

@ShermanP

Yes it is still available to run portable.