Unknown device does not have a driver, Arduino driver issue

Hey guys,

So I'm on a school computer(Windows PC, important as I cannot access the device manager to fix this) trying to work on a project. I plugged my Uno in, and it tried to get a driver, but it failed. I went to devices and printers and right clicked on the "unknown device". It required admin permissions so I had to get someone to enter the admin information. It started its troubleshooting, found that it needed a driver, tried to install it, but it failed and stated that the unknown device does not have a driver. Any fix for this? I need to complete this project.

Additional note, on the actual IDE, it gives me the not in sync error.

Just install driver from device manager. You need to select proper driver location. Can you share how you installing.

If i am installing driver.

I would go Device manager-> chose board -> driver update-> instal from specification location

Chose arduino folder contain the Drivers for USB -> OK.

If admin has locked ? You can get easily permission for the administrator explaining installation process steps