Unknown device on device manager

I have arduino UNO clone with ch340g chip. I connected a servo motor by it's 5v supply and regulator burnt due to overload while 12v external supply was provided. (First I assumed it may have overload protection) I safely removed regulator by desoldering it from arduino board.

However I still could use arduino with usb power without problem. after few hours of use, the arduino does not recognized by my PC. when I connect usb cable, the PC tries to install driver, but unknown device is listed on device manager. I tried manual installing ch341 driver but not worked. my other arduino board (same type) works without problem.

I tried to burn bootloader with arduino as ISP. but still not solved. I can program it with arduino as ISP option. but no usb connection works.

any help would be highly appreciate to solve the USB connection problem with my arduino UNO clone. Thank you.

Could be more than the regulator that you fried.

Buy a new one and chalk this one up as a learning experience.
The clones are usually better at handling voltage than the real ones so maybe double check WHY it happened in the first place. (bad wiring, too many current drawing items on the pins, etc.)