UNO all lights on (solved)

Hi
I'm newbie in Arduino and electronics and really enjoying it.
thanks Arduino for making things more simple.

I have written a code but when I upload it to my UNO board all lights includes on led, rx led, tx led and L led attached to pin 13 is on.
the pin 13 itself has no lights when i attached a led.
what could be the problem.
i tried many of examples and they were working good so I'm sure the board it self is healthy.
thanks for answering.

westsun:
I have written a code

Let's see it then :wink:

Here it is:
https://paste.ubuntu.com/25580797/

You shouldn't use pins 0 and 1 because they are used for serial communication with the computer. The onboard LED L is buffered so it lights when the pin 13 isn't pulled low.

but i'm not using pin 1 and 0 data input or output after uploading the sketch.
i tryed to make pin 13 as output but still had the problem.
thanks for answering

When the pin 13 is set to OUTPUT LOW, the LED L switches off. Using pins 0 and 1 may confuse the onboard USB-serial converter and the RX/TX LEDs will light. You can use analog pins as additional digital pins.

Hi,
Welcome to the forum.

Please read the first post in any forum entitled how to use this forum.
http://forum.arduino.cc/index.php/topic,148850.0.html then look down to item #7 about how to post your code.
It will be formatted in a scrolling window that makes it easier to read.

Can you please post a copy of your circuit, in CAD or a picture of a hand drawn circuit in jpg, png?

Thanks.. Tom.. :slight_smile:

of course i will make it public but when it's finished.
i think everything is working now just need to modify the code to use right pins and one day test.
if it passes the test we can have a color_watch with minimum hardware.

TomGeorge:
Please read the first post in any forum entitled how to use this forum.
http://forum.arduino.cc/index.php/topic,148850.0.html then look down to item #7 about how to post your code.
It will be formatted in a scrolling window that makes it easier to read.

Thanks Tom I tried to post the code in here but I got an Error of limitation of 9000 words in 1 post, so I used UBUNTU paste service.

Hi,
Attach it as an ino file , if it is too big.

Thanks.. Tom.. :slight_smile: