Uno board not recognised

Hi all.
I just bought an Uno board and a starter kit.
The kit included a USB cable.
When powered up I wasn’t able to see the board/com port in the arduino software. The lap top operating system reported a code 43 fault, USB port. Laptop device manager reported USB connection unknown. Arduino software had port selection greyed out.
Tried to upgrade driver but no luck there.

Tried a new cable and got results, arduino software recognised uno board and assigned a com port number which I was able to select. Was able to upload a program ok. RX/TX leds active during upload.
Laptop device manager then showed a com port connection but nothing new in USB directory.

However the next time I tried to upload a new program the verification process failed.

Would appreciate any suggestions as to wtf is happening.

More information is needed !

Where did you buy it (link please) ?
Is it a clone or a true Arduino ?

Sounds like a windows OS but which one ?
43 is usually a driver related issue so some help for that in the links below.

Could you also take a few moments to Learn How To Use The Forum.

Other general help and troubleshooting advice can be found here.
It will help you get the best out of the forum in the future.

Sorry guys,
I bought the board from Jaycar and have tried using both Windows 7 professional and Vista.
Strange thing is when I used another USB cable the laptop recognised the Uno board and downloaded the correct drivers automatically. No error messages such as code 43 or unknown USB port.
This setup worked once , so not sure what is happening.

You may have some minor issues with Vista but you also didn't read the links I gave you otherwise we would have had a link to the exact board you have.

Jaycar tend to be a reputable supplier but without going to the site and hunting around I have no idea if they also sell clones ?

As for working with one USB cable an not another then that is a very common issue as USB cables can go bad with zero warning.