Uno Board Partial Malfunction?

My Uno board (Atmega328p- pu) seems to have a partial malfunction. I’m working through the basic sketches, such as blink, etc. I jumped to “Sweep” and it worked fine for 2- 3 steps and seemed to be at the end of 180 travel, but did not go into reverse back down to “0”. It stayed their ticking away until I pulled the plug, and tried modifying the code to bring it back around, but no movement at all after re- uploading. I re-upped “Blink” to see if that would run and it was fine, so I did a reset, and upped “Ping”, it only displays 0,0 in the Serial Monitor, nothing more.

Setup went without issues, Win7 64 bit, com3 was recognized and initiated, so am looking for pointers on what next.

Thanks, Beachside Hank in sunny Florida

So this does not work? http://arduino.cc/en/Tutorial/sweep

That is correct. To your knowledge, can a board be only partially functional, i.e. execute some simple sketches, but not others?

Blink works but sweep doesn’t.
Tell us what happens when you upload the sketch.

The led’s on the board dim considerably, no action from the motor, no detectable noise either (hum, vibration, gear chewing etc.)

Are you powering the motor from the Arduino?

Yes, it is the small one included in the starter kit from Odd Wires:

Power it with external power supply not the Arduino.

Thanks, I'll try that.