Uno Cannot Connect to Network with Ethernet Shield

I bought an Ethernet Shield for my Arduino from Radio Shack and I haven't been able to get any of the ethernet tutorials to work and I haven't found anyone on the web with the exact same symptoms that I have. Below is some data of what I have and what I've tried:

  • I am using the Arduno Uno R3 SMD Edition
  • I am using the W5200 Ethernet Shield v2.2
  • I am on Mac OS 10.6.8 with Arduino IDE 1.0.6
  • The chat server tutorial returns: Chat server address:0.0.0.0
  • The DHCP address printer tutorial doesn't print anything and gets stuck on the line if (Ethernet.begin(mac) == 0) {
  • I have tried the following network configurations:

  • I have tried with different MAC addresses on the WebServer tutorial

  • I have tried with different IP addresses on the WebServer tutorial

  • Plugged the Arduino into two different routers

  • Tried with DHCP both on and off on the routers

  • Plugged the Arduino directly to my computers ethernet jack

  • Put a network switch between my computer and the Arduino

  • Tried with three different ethernet cords

  • I did not have an SD card plugged in when I tried the ethernet tutorials

  • I tried plugging the Arduino into an external power supply

  • I HAVE gotten the Arduino CardInfo tutorial to work with the ethernet shield

I have discovered more information that may be useful.

Without inserting the SD card, I added these two lines to the setup section for the Web Server tutorial: pinMode(4, OUTPUT); digitalWrite(4, HIGH);

The serial output that resulted from this change is: server is at 175.45.199.175

When I tried to ping the address the serial console gave me this very strange, interesting response: ping 175.45.199.175 PING 175.45.199.175 (175.45.199.175): 56 data bytes 36 bytes from 192.168.2.1: Destination Net Unreachable Vr HL TOS Len ID Flg off TTL Pro cks Src Dst 4 5 00 5400 de92 0 0000 3f 01 638f 192.168.2.2 175.45.199.175

This response is unlike any other response I usually get from ping, which usually says something like Request timeout for icmp_seq 0.

Here are some conditions for the response: - This only works when the router has DHCP mode turned on. - The DHCP IP pool range is 192.168.2.2 to 192.168.2.100 - The IP address I gave to the arduino is 192.168.2.101. - When I tell the Arduino to use 175.45.199.175 as its address I do not get that response. I'm wondering if I need to place a jumper between two pins. Help would be appreciated.