UNO: code won't run after power cycle

Hi

I have a problem with one of my Arduinos,

Arduino UNO with removable 328/28p (official Arduino board)

  1. Code uploads fine
  2. Code runs fine
  3. Unplug USB
  4. Plug in USB
  5. Code don't run, LED 13, three fast flashes repeating ,
  6. Re-upload code, fine
  7. Code runs fine
  8. etc....

I've got a bunch of atmega 328s preloaded with the UNO boot loader from Sparkfun, i've tried 3 different 328's one the board, and i got the same behavior.

The code runs fine on the MEGA 2560 and Arduino Pro (Sparkfun) even after a power cycle.

Has anyone got an idea whats causing this behavior?

Thx

Silverviper

When you plug in the USB and the code doesn't run have you tried pressing the reset button?

Hi

yes i’ve tried pressing the reset button,
the series of three flashes on led 13 halts for a second
then continues flashing

THX

Silverviper

In which case I would say there is something wrong with the boot loader software. There is no way code can run unless it is stored in the flash, so a power cycle must be activating the boot loader as that is the only thing that can change the program area of flash. Try reprogramming the boot loader.

Use the latest Optiboot.

Hi

burnt a new bootloader, UNO is working again :slight_smile:

thx guys

Silverviper