UNO isn't powered or seen by Mac

Hello all

Here is the problem - original Arduino UNO is not seen or powered by Mac (High Sierra). All worked well before when I tried to upload Scratch 4A sketch and right after that board became not recognisable and LEDs are not up. When I attach external power - both LEDs are up. What I tried:

  1. Ring out the breaker - good
  2. Nothing heats up on the board and all the contacts and chips look good
  3. Applied both external power and USB - LEDs are up but still not seen by Mac
  4. Tested voltage on the board at the USB connector - it receives 5V
  5. Changed USB cable - didn't help
  6. Tried with iMac and MacBook Air - same thing

Another thing - I do not see any COM ports in Tools - Ports list. If I remember correctly it was at least one when I installed Arduino first time and all worked. Could it be parts of one problem? Should LEDs be up even without proper connection? There are no COM ports listed under USB section of Mac's System description either.

I tried installing FTDI and CH341SER but than found out that MEGA chips work with standard MacOS drivers.

Any hints?

The LEDs only mean that the board is getting power. They don't tell you anything about whether there is a data connection.

That it used to detect, but now doesn't, is a bad sign regarding the state of the USB-serial adapter. The mega16u2 used as serial adapter is known to be prone to failure, typically from abusing the power rails in some way, but occasionally from perfectly correct connections when using USB and an external power source at the same time, or a motor shield.