UNO MD-328D Verbindungseinstellung ?

Hallo Gemeinde,

mir wurde hier einmal der UNO empfohlen. LINK

Nun habe ich das Problem, dass die IDE keine Kommunikation hat.
Ich habe vom Hersteller LINK die Treiber? eingespielt, man hat nun Boards zur Auswahl, dennoch kann ich kein Sketch downloaden?

Steh da etwas im Wald, ich weiß dass ich hier ansich nicht richtig damit bin und um Hilfe fragen sollten, hoffe aber trotzdem auf konstruktive kleine Hilfe.

Danke!

(deleted)

Ich nehme den wohl…

Denn die Dinger bringe ich gerne zum Einsatz.
Die zusätzlichen Features sind schon hübsch.
Und mein Chinesisch ist ist seit dem auch viel besser geworden.

ich versuche es gerade am Macbook, bekomme die Support-Package von MassDuino einfach nicht drauf, Sketch startet dann nicht mehr ...

eine originale Installation mit UNO zeigt einen Fehler mit "programm is not responding", müsste ich da einen anderen auswählen ?

Da steeht aber "Programmer is not responding", und den Programmer brauchst du zum Flashen nicht auswählen.

Einfach nur hochladen klicken.

Geändert, da falsch ausgedrückt.

hab es nun gerafft das Support-Package zu installieren, im Sketch kann jetzt ein Board ausgewählt werden, auch den Programmer hat er verändert, dennoch selbe Fehleranzeige.

HotSystems:
Da steht aber "Programmer is not responding", und den Programmer brauchst du zum Flashen nicht.

OK, wie schalte ich das dann aus?

Und nochmal, du brauchst keinen Programmer.
Du hast diesen seltenen, nur für diese Chip Familie tauglichen, Programmer nicht.

Naja, eine 'Programmer' braucht man schon. Aus Sicht des avrdude, der zum Hochladen verwendet wird, ist auch der Bootloader ein 'Programmer'. Und wenn sich der Bootloader nicht meldet - oder falsch meldet, sagt der avrdude auch 'programmer not responding'.
Den zum Board/Bootloader passenden Programmer wählt die IDE aber selbst aus, wenn Du den Sketch 'normal' hochlädst, also über den entsprechenden Button. Und natürlich muss die passende Software zu diesem 'Programmer' ( und sei es eben auch nur der Bootloader ) dann auch vorhanden sein. Die Auswahl des Programmers im Werkzeuge-Menü ist dann irrelevant und wird ignoriert.
Nur wenn Du den Bootloader brennen willst, oder den Sketch ausdrücklich über einen selbst definierten Programmer hochladen willst ( Menü->Sketch->Hochladen mit Programmer ) dann ist die Auswahl unter Werkzeuge->Programmer relevant ( muss dann aber natürlich auch zur angeschlossenen HW des Programmers passen).

Tja, ich bin überfragt.
Was kann ich jetzt tun?

4711:
Tja, ich bin überfragt.
Was kann ich jetzt tun?

Nur auf Sketch hochladen klicken.

combie:
Und nochmal, du brauchst keinen Programmer.
Du hast diesen seltenen, nur für diese Chip Familie tauglichen, Programmer nicht.

Guten Morgen, ich habe das angehakt, keine Veränderung. Im Mac sehe ich im Menü 2 Pkt. zu hochladen, ich drücke nur laden, selbes Ergebnis.
Mir kommt vor, der hat keine wirkliche Verbindung via USB.

4711:
Guten Morgen, ich habe das angehakt, keine Veränderung. Im Mac sehe ich im Menü 2 Pkt. zu hochladen, ich drücke nur laden, selbes Ergebnis.
Mir kommt vor, der hat keine wirkliche Verbindung via USB.

Dann wird das wohl so sein.
Fragt sich nur, wo da der Fehler liegt.

ich habe das angehakt, keine Veränderung.

Natürlich gibt es da eine Veränderung!
Denn die Ausgaben werden umfangreicher.
Aber ok, wenn die dich nicht interessieren....

Was sagt es denn bei "Boardinformation holen"?

Mir kommt vor, der hat keine wirkliche Verbindung via USB.

Es interessieren nur Fakten.
Vermutungen lenken ab und führen in die Irre.

CH340 Treiber richtig installiert?
Richtigen Port ausgewählt?

der CH340 Treiber vom Hersteller hat mit meiner Mac Version nicht funktioniert, ein alternativer zeigt mir nun einen weiteren Port an, den ich auswähle.
eine Boardinfo kann er holen, unbekanntets Board, VID u PID mit Zahlen, SN: laden sie ein ....

dann kommt diese Meldung

avrdude: Version 6.3-20190619
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "/Users/xxxx/Library/Arduino15/packages/arduino/tools/avrdude/6.3.0-arduino17/etc/avrdude.conf"
         User configuration file is "/Users/xxxx/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/cu.wchusbserial1410
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00

VID u PID mit Zahlen,

Das wäre aber schon wichtig, die Zahlen zu lesen, und so sehen zu können, ob du den richtigen Port ausgewählt hast.

Auch:
Ein Gegentest mir Windows sollte zeigen, ob du ein Problem mit dem Board hast, oder mit deinem Mac.

BN: Unbekanntes Board
VID: 1A86
PID: 7523
SN: Laden Sie irgendeinen Sketch hoch, um sie abzurufen

Super! Win kann den WCH Treiber nicht installieren... "Installation Failure"...

VID: 1A86
PID: 7523

Das sieht gut aus!

Win kann den WCH Treiber nicht installieren... "Installation Failure"...

Das bekommst du auch noch hin.

Morgen!

aufwändig... Win nur in der Konsole hat es den Treiber installiert...
ich habe Sketch de-/installiert, Bibliotheken update gemacht, Inhaos Boards installiert

beim ersten Mal übersetzen kommen unzählige Fehlermeldungen zu den Bibliotheken usw, ist das normal??
beim zweiten Mal nichts mehr davon

UND es war wie üblich das USB-Kabel, mit dem 3. gings dann, nun hat er endlich den Mini-Sketch geladen.

Tests müssen nun zeigen, ob das auch läuft.

Ach nee, nein es ist nicht das USB-Kabel !

ich habe 2 von diesen UNO LC und tatsächlich einer davon macht die Probleme.

Nun stellt sich die Frage, ob man da etwas flashen kann (Bootloader) ?? damit der auch wieder wird ?