UNO no upload: Ubuntu or Windows

I bought an Arduino UNO with the 328 chip. I run Ubuntu 9.10 and installed the IDE according to the instructions at
www dot arduino dot cc/playground/Linux/Ubuntu

At first, when I plugged the USB cable in, the green LED was on and the yellow LED blinked four times long and on time short. Then I started up the Arduino IDE which was version 18. I set the board to Duemilanova and 328. Under Serial Ports, only /dev/ttyS0 showed up. I selected it. I loaded the basic blink example and compiled it. When I tried to upload it, I got the error message:
“avrdude: stk500_recv(): programmer is not responding”

I ran dmesg and got
cdc_acm 1-2.6:1.0: ttyACM0: USB ACM device

From the site at
frontlinesms dot ning dot com/profiles/blogs/2052630:BlogPost:8414
I got that I should run the command
sudo ln -sf /dev/ttyACM0 /dev/ttyS0

After that, I got the error message
avrdude: stk500_getsync(): not in sync: resp=0xf9

Now the yellow LED does not blink anymore when I power the board up. I am thinking about reinstalling the boot loader.

In the mean time, I found out that only the latest Arduino IDE supports the UNO (version 21.) With it, I can select Tools->Board-> Arduino UNO, and under Tools->Serial Port I can select /dev/ttyACM0. Even with this configuration, I get the error
“avrdude: stk500_recv(): programmer is not responding”

I tried Ubuntu 10.10-same problem.

At least, after pressing “Upload” the yellow LED’s flicker for a while so I know the board is communicating. I also noticed that when I start the serial monitor and send a character, one of the yellow LED’s on the board goes on briefly in response. This is consistent.

I tried to upload the blink example from Windows. I followed the instructions at
arduino dot cc/en/Guide/Windows
exactly and still end up getting the same error:
“avrdude: stk500_recv(): programmer is not responding”

What should I do?

I get the sense that the software has not caught up with the UNO. I have ordered a Duemilanova - hopefully, that board will work.

I think for the UNO you need the 0021 from the downloads page. Shouldn't be a problem running it on your machine, just download, extract and doubleclick 'arduino'. If it doesn't work right away try leftclicking arduino and check the rights for it, make sure the run-as-program box is checked. Hope this helps.

You definitely need IDE ver 0021 with UNO - I had a similar problem after uploading the OneWire sample sketch under Linux - the sketch was failing and it stopped me from re-setting or reloading any other sketches. I fixed it by reloading the Blink sketch under Windows - not sure why this worked. The sketch ran perfectly on my Duemilanove by the way.

Hi all,

thanks for your replies. I was using version 21, set the board to UNO, and set the serial port to one that communicates: COM3 under Windows and ttyACM0 under Ubuntu. Still no luck.

Any further ideas?


Hi arduniomstr,

your post has given me a possible clue. Perhaps the failed upload under Ubuntu has messed up the board so that now it does not even work under Windows any more?

Update: it works now. Please see