Uno Port is greyed out on IDE. Multiple troubleshooting fixes attempted

Seems to be a common problem but i've been working to get it resolved for over a week. I'm brand new to this, started researching about a month ago and finally decided to give it a shot. A buddy of mine gave me his old arduino uno starter kit that he purchased from a radio shack a few years ago. It doesn't appear to be the chinese knockoff, although admittedly i'm not entirely sure how to tell. (it says made in italy, also says atmega328P...i can't find any CH340 markings). i plugged it in and downloaded the IDE from, and have never had an option to select a port. a list of things i've tried:

  1. went to wife's mac and downloaded the iOS IDE. i have only one port option but i don't think it's the right one. i'm not as familiar with iOS so i didn't do much else to get that to work.
  2. thought since it wasn't working on wife's mac, could be a bad cord. bought new cord, no luck.
  3. drivers...went into device manager and manually updated the drivers, making sure it was looking in the right folder
  4. found a random troubleshooting tip online that had me go into the preferences.txt file and manually add the COM number that appeared in my device manager
  5. uninstalled and reinstalled the IDE

The uno board does light up when i plug it in, but my computer doesn't seem to be recognizing it. is it possible the uno itself is bad?

A few other things to note...when i have device manager open and i plug-in/remove the usb cable, nothing appears/disappears. in fact i had to manually go in and "add legacy hardware" in order to get the ports (com and lpt) option to appear. i'm also not the most tech savvy guy on the planet so i'm not sure if that means anything. I've tried all 3 usb ports on my PC. all three work when other devices are plugged in (usb storage devices).

Next step is to go back over to buddy's house and plug the same uno into his machine to see if it works, but i won't have time for a few weeks.

Any help would be appreciated.

You've been doing a very good job of checking all the usual suspects for this problem.

If nothing is showing up in Device Manager when you plug in the Uno, then you know it's not a driver problem. If it was a driver problem then you would get an unknown device in Device Manager.

Next I would have suspected the USB cable, but you already eliminated that.

The only thing I can suggest now is that you make sure the USB cable is fully plugged into the Uno and the computer.

If there are any components or shields plugged into the Uno, you should disconnect them while troubleshooting the problem.

Make sure the Uno isn't lying on any conductive surface or anything like bits of wire or coins.