Uno R2 -> bootloader on 328P-PU on breadboard

Hi,
I have tried everything I could find, but I can’t get my UNO R2 to burn the bootloader on my new Atmega328P-PU chips on a breadboard. :frowning:
I tried the ArduinoISP instructions with and without the Xtal and I tried the OptiLoad sketch. Nothing seems to work.

Here’s my setup:

  • Windows 7 Pro and Arduino IDE v1.0
  • Arduino UNO R2
  • New Atmega328P-PU on a breadboard hooked up like the setup at the bottom right on the ArduinoISP page.
  • Added a 10uF cap between reset and GND.

Here’s what I did:

  • Hooked up the clean Arduino UNO R2
  • Set the board in the IDE to Arduino UNO
  • loaded the ArduinoISP sketch from the examples and burned it to the Arduino → no errors, verification successful
  • Unhooked the Arduino board and connect everything up like the bottom right setup on the ArduinoISP page
  • Close Arduino IDE
  • Add the 10uF cap between Reset and GND
  • Hook up the Arduino board (power LED on breadboard lights up)
  • Start Arduino IDE
  • Set board to Arduino Duemilanove w/Atmega328
  • Set programmer to Asduino as ISP
  • Select Burn bootloader
  • I get error below

avrdude: Device signature = 0x000000
avrdude: Yikes! Invalid device signature.
Double check connections and try again, or use -F to override
this check.

I recreated the circuit three times now. Same error, so I doubt very much the connections are the true culprit. I attached a picture of my setup.

I tried again using the Arduino Nano w/ATmega328 board selected. I get the same error. :frowning:

I also tried using the OptiLoad sketch from WestW, but the IDE complains about missing OptiLoad.cpp files and I can’t find any instructions on how to use the sketch in Arduino IDEv 1.0. Where do I need to put what files? WestW, if you read this, contact me and I’ll write out a manual when I get things working.

I used Google and found a LOAD of references using other Arduino boards. I also found a lot of people saying they had no problem using the Arduino UNO and the ArduinoISP instructions (with and without the CAP). I doubt those latter people were using the UNO R2. :-/
Nothing worked with my setup.
I uploaded sketches I wrote to my board and these work fine, so I doubt very much my board is bad.

I ran out of options … Please help!?

Bert

I would replace the capacitor with a 120 ohm resistor from reset to 5v on the R2 uno.

Look in the microcontroller section for the thread started by JimG it helped me a bunch.

I tried with a 120 ohm resistor between reset en gnd. Same problem. :-( I added the LEDs on pins 7, 8 and 9 to monitor the situation. When the resistor is put on the reset-gnd the heartbeat monitor LED on pin 9 does not light up. When using the 10uF cap it does light up. When starting the bootloader upload the programming LED blinks and then the error is shown in the console.

I had already read the thread you mentioned but half of it is way over my head and the other half is not applicable to my situation. Why can't this be a lot easier????

You want a pull-up on reset, not a pull-down. (it's RESET with a bar -- meaning it's inverse) Try a 10 kOhm pull-up on the reset pin. I would try without the capacitor, too -- the AVR does fine auto-reset on its own when powering on, and the programmer pulls reset as needed. Also, you can totally say that you're targeting an Uno board when programming through an ISP.