Uno R3 as ISP to burn ATMega8 bootloader

Hello guys! I bought an ATMega8 today and I want to use it as a standalone project handler.
I used this tutorial. I made the Minimal Circuit (Eliminating the External Clock).
The problem is that I can't burn the bootloader to the ATMega8.

I'm using Arduino NG or older w/ ATmega8 (COM 3 if that's necessary).
The error I get is:

avrdude: Yikes! Invalid device signature.
Double check connections and try again, or use -F to override
this check.

As a disabler for the auto reset I use a capacitor (10uF connected to the GND and RESET).
Can you help me?

I am having the exact same problem! I tried the pull-up resistor on the reset pin. I tried the two bypass caps on the power pins. I tried changing the hardware configuration files for the ATMega. Nothing yet. I would really appreciate some further help on it.
Good luck!

One of the problems is that if you use the "Arduino NG or older w/ ATmega8 " you set
the fuses to expect an external x-tal, and as you haven't provided one you get an error.

I have build a bare bone Atmega8 board without x-tal and used the below in my bords.txt.

You can just copy/paste it into your boards.txt as the last entry:

atmega8b.name=Arduino BB Internal 8MHZ

atmega8b.upload.protocol=arduino
atmega8b.upload.maximum_size=7168
atmega8b.upload.speed=19200

atmega8b.bootloader.low_fuses=0xd4
atmega8b.bootloader.high_fuses=0xc4
atmega8b.bootloader.path=atmega8
atmega8b.bootloader.file=ATmegaBOOT.hex
atmega8b.bootloader.unlock_bits=0x3F
atmega8b.bootloader.lock_bits=0x0F

atmega8b.build.mcu=atmega8
atmega8b.build.f_cpu=8000000L
atmega8b.build.core=arduino
atmega8b.build.variant=standard

Probe with the "new board" but I still have the same problem