UNO R3 could not upload. Solved here!

I'm hoping this may be of some help to some wit the same problem.

I have been working with the ESP8266 Node MCU 1.0 for a while. I had never used the UNO before yesterday on this particular machine and only a couple times on my laptop.

AMD A-10, Win 10 64. Nothing else out of the ordinary except I run Com0Com for remote radio software.
COM 3-7 are in use by Silicon Labs drivers and Com0Com. Com 19 is used for the 8266 boards CH-340 drivers. Com 8 was chosen by the Arduino drivers. Board is an ELEGOO R3 knockoff.

When I plugged in the board into this machine everything was fine but ti would hang on upload. The upload would never finish. I went through all the troubleshooting I found here and the loopback test would even hang the software and require that I kill the process in task manager.

I uninstalled and reinstalled the drivers, the IDE, changed the port number to 9 and disabled com0com.

I finally changed the com port to 25 just............ because..........I have no reason for doing it other than I saw 19 was chosen by the CH340 drivers. No other reason.

IT WORKED! I have no idea why. Maybe someone here does and can explain it. All I know is it works on Com 25.

That is quite strange but I'm glad that you were able to find a solution. Thanks for taking the time to share it here!