Uno r3 multiple com ports

I'm having problems with com ports and the Arduino uno R3. I have 2 Arduino Uno's. I was developing with one when it all of a sudden would not connect to the com port anymore. When connecting the USB to it I get com6 in device manager. But when trying to upload I get the dreaded error 'avrdude: stk500_getsync(): not in sync: resp=0x00'. So I diconnect the usb connection and plug in the other Arduino Uno R3. Now I get in device manager com7 for the arduino and the com6 disapears. Uploading to this Arduino works fine. Why would 2 different arduino uno r3 boards install different com ports?????? The com port 6 on the first arduino worked fine for weeks until today. I've tried all the solutions in the troubleshooting section along with other forum solutions to no avail. - This is a windows xp machine. Any ideas? TIA MIke

This is what is supposed to happen, at least with the port enumeration anyway. Even though the devices have identical VID and PID values, they still have a unique number inside that windos pays attention to.

No idea why you are getting the error unless you've got the wrong baud rate to talk to the bootloader or something else is wrong with it. Did you do any tinkering with ArduinoISP?

thanks for the reply afremont :) I will be installed the arduino download version 1.0.5 on my windows 7 machine and see if I get the same results. Also, my Tools->Programmer is set to AVR ISP mkII. I'm assuming this is the default. I'll keep you posted on my results. thanks

The Tools-Programmer setting is only used when you select Burn Bootloader

When selecting Upload, the only settings used are Board and Serial Port.

Is the Loopback test successful on the board you are having trouble with?

I’ve tried getting it to work with my windows 7 machine.
One works fine and uploads with no problem. The other one does not.
I think the USB interface is ‘TU’ .
Is there anyway to replace the USB interface on a arduino uno r3 board.
Its probably that tiny little surface mount guy. bummer.
thanks for all the replys.

You can use the working UNO as a programmer and try to reprogram the USB to Serial device on the non-working one.

You can follow this tutorial for using the ArduionISP sketch:

The firmware you want to load on the 16u2 is located in your Arduino software package: arduino\hardware\arduino\firmwares\atmegaxxu2\Arduino-COMBINED-dfu-usbserial-atmega16u2-Uno-Rev3.hex

You will need to connect the ArduinoISP to the six pin header located in the upper left hand corner, near the AREF label.

Thanks Louis.. I'll give it a try. appreciate the help.