Uno R3 not recognised (solved)

Hello,
I just unpacked my Arduino Uno R3 and followed the getting started manual. My computer still doesn’t reconise the board and only displays it as a unknown device. I downloaded the drivers but when I click on update drivers and then manually go to the driver file I downloaded, I get a message saying “there is are no drivers found”. In the troubleshooting manual it says I must go to device manager, where I should fine my Uno under Ports (com and LPT) however my Uno is called unknown device and falls under the tab other devices. I’m running windows 8 and I attached a screenshot. Also I have a arduino Nano and my pc reads that one just fin. Thanks for any replies.

Anyone any ideas?

Make sure you are using Arduino IDE 1.04.

Here is the process to correctly install the Arduino drivers:

Right click the Unknown Device in Device Manager
Select Update Driver Software
Select Browse my computer for software
Click Browse button
Select the Drivers folder under the location of your Arduino software installation. (Do not select the FTDI folder inside the Drivers folder)
Click OK
Click Next

For any one with the same issue and is trying to install on windows 8 use Erieds post to help out. Arduino Forum

Thanks,
Sorry I just missed your post before placing mine. But thank you anyways.