UNO R3 Usb and Win 7

Hi Everyone.

I did a lot of searching but could not find a solution.

Win7 does not work , But Win10 works ( plug and play.)

My UNO R3 does not connect to usb with Win7.. "unknown device" in device manager.

The USB chip is the original Mega 16U2.

I tried updating driver..pick from list..Arduino/drivers..ERROR COULD NOT UPDATE.

Search pc and internet ..NO driver found.

Was this issue ever resolved for Win7 with the Mega16U2 chip.(UNO R3)

There must be thousands of Aduino users with Win7 and the UNO is very popular so the UNO R3 cannot be used on Win7??

There seems to be a missing file ..Arduino UNO.inf , I searched my pc but could not find it.(Win7).

Thanks for any advice.

My first ventures into Arduino were on a Win7 machine and I never had the problem.

Not sure if you can get to it (because of above), but can you determine the VID and the PID? In device manager, right click the unknown device, select properties, go to the tab Details and from the dropdown select Hardware Ids.

The specific driver is in the IDE subfolder "drivers"
FORUM search should also find you some relevant details too.

Only changed to win 10 here last year and had no issues same as sterretje.
Things that can cause driver issues usually boil down to additional security or a policy in effect on a loan computer (EDU / CORPORATE)

Often installing (re-install) the IDE as a full administrator can help.

Thanks for the reply.Sorry for not giving all the info.

Arduino UNO R3.
Win 7 64Bit Proffesional..Bitdefender security..full access to pc.
Arduino 1.8.13

I did uninstall the Arduino ide and re install it ... no change.

I can read the VID,PID.

In Programfiles/Arduino/Drivers..there is no Arduino UNO.inf file.

There is a Old_Drivers zip file , with the Arduino UNO and UNO R3 Drivers.

I did unzip the folder and then with the update--select from list--have cd --browse to the unzip folder and select Arduino UNO R3 ..this also fail to update.

There is actually a lot of UNO R3 Win7 usb driver failures that I found in Google.

They get solved by 2 options move to Win10 or the UNO use the generic CH340 chip that then work after installing the correct driver.

Might be the driver is only 32 Bit ..Note that I have Win7 64 Bit.

Did you verify that they are what the are supposed to be?

I have also been using the 64bit win7 and win10. Not behind a PC to verify but there are, if I'm not mistaken, 64bit drivers somewhere in the driver directory.

I dont know what the VID,PID should be.

I also now do agree that the UNO R3 can work on a Win 7 64 bit pc ..just installed Arduino ide on another pc with win7_64Bit and the driver works!

I then uninstalled Arduino(again) on my pc ,dissable the antivirus and re install.

What I notice is that my pc does not ask permission to install the usb drivers (log in as Administrator and Run software as Admin).

But the working pc ask I think 4 times if I want to install a this usb driver.

Then from Programfilesx86/Arduino/Drivers ...Run as Admin ..(dpinst-amd64.exe)
this fails ..cannot install drivers.

This above test was done with the working pc and installed a few drivers succesfull.

Seems like something is blocking the installation of the usb drivers on this Win7 pc.

This was a hint to post it if you could not figure it out :smiley:

But that is probably no longer useful as it's working on another PC; I don't think that I can help you further.

Because you got it working on another win 7 box it would indicate a local issue.
IIRC bitdefender may not fully disable like some other antivirus does.
After you disable it double check in both SERVICES and PROCESSES that none of the bitdefender items are still running.

I may be wrong but I think a few others have had a similar issue.
Know that in at least one case they removed the AV to install the IDE and drivers.
With that in mind I have attached some additional instructions.

CLEAN UP BEFORE INSTALLING ANOTHER COPY OF THE IDE OR ARDUINO CREATE.pdf (346.7 KB)

Thanks for the replies.

The VID and PID id's is the same on both working and no-working pc.

Funny that the pc that does work also have Bitdefender and I did not stop it and also did not run as Admin..but Arduino was never installed on that pc.

I will follow your pdf info and see what happens.

They are board 'parameters', vendor id and product id. So it would be strange if they would change between computers :wink: