UNO R3 will not communicate with Mac OS 10.6.8

I've just purchased a new uno R3 and can't get the basic BLINK script to upload. I'm using IDE 1.1 on a MacBook with OS 10.6.8. I have all permissions on the Mac. I've tried new cable, loaded the FTDI ( although not needed) and still get the same error.

Arduino sees the board. The Serial connection is listed as tty.usbserial. Should that be tty.usbmodem ??
The board is getting power is simply fails the upload.

Any suggestions? I thought this was supposed to be easier on a Mac.

On my Mac it shows up as:


The number would almost certainly vary.

This is OS/X 10.7.5.

Nick, thanks for the input. I assume that you did not need to install the FTDI on your Mac??
Did the Arduino board show up as "usbmodem" initially? I'm still seeing "usbserial".
I think I'll try upgrading the OS but I don't think that is the issue.

OK Mac users, let me hear your input on this one. Thanks. :smiley:

"Usbserial" implies it is not a geniune Uno. Where did you buy it?

IT appears that is correct. It came from Fry's as part of an Arduino starter kit. It's an OEM board from OSEPP.
Uno R3 Plus. Does that have a direct bearing on the process needed to communicate with the board given the open source of Arduino

OSEPP intentionally mislabels their boards.

You probably DO need the FTDI drivers and you probably need to select "Duemilanove" in the board list. You should also consider using their support forums since they do nothing to support the Arduino project.

I've just purchased a new uno R3 ...

More information always helps. I took that to mean "genuine Uno", not some knock-off.

I'm not judging here, but different manufacturers can use different interface chips, or if it is the same chip, different firmware. As James says, perhaps ask on their support site?

OK Arduino experts I solved the problem. I'm actually using an SOEPP Uno R3 Plus. I have been trying to upload to an Uno Board. The documentation indicates that my board is using an ATmega2560 chip. I starting trying other board types and discovered that selecting the Duemilanove w/ ATmega328 made everything work. Go figure.
Thanks for your input.

Now on to programming neat stuff.

Nick, I didn't notice your post until I replied back to the forum. Thanks you specifically for your time and interest. You were right on the spot. Thanks for giving a struggling newbee a shot in the arm. Greg

The documentation indicates that my board is using an ATmega2560 chip.

So you have something that says "uno r3" and "atmega2560" on it?

I wouldn't spent one more second with it. Return it. Clearly, you have been deceived.

There's nothing "Uno" or "Duemilanove" that uses the 2560.

I am using this same Osepp product with a macbook running OSX 10.5.8, and I have gone through these same processes but I'm still getting the "avrdude: stk500_recv(): programmer is not responding" message. I'm going to look on the Osepp forums now I guess, but does anybody think my problem could be connected to me using OSX 10.5.8? It seems everyone I've read about has been using a later version of OSX than I am. Thanks in advance for any help.

but does anybody think my problem could be connected to me using OSX 10.5.8?

No that has nothing to do with it.

I'm not sure what happened, but I've got the Blink sketch working on my board now; it seems to be working fine. I tried switching from Arduino Duemilanove w/ ATmega 328 back to Arduino Uno under file > board and it immediately started working. This was the very first thing I did last night, so I don't know what the problem was. I downloaded the ftdi driver a couple of times from two different places I think so maybe that fixed the problem a long time ago. Thank you for the help!