UNO Rev Unrecognized USB Device after successful install Win7-64bit

Hi all, Just finished read all the FAQs and postings regarding installation of V1.0.3. As indicated in the FAQ my UNO Rev 3 came as an unknow device. I followed the instructions to install the driver with success. Once I went to upload a test file, the UNO did not respond. After a replug, reboot etc the UNO now comes up as an "Unknown Device" under Universal Serial Bus controllers. I have tried several times now to delete the driver and re-install the driver manually however when I select UNO Rev 3, Windows 7 comes back saying it is incompatible. So I have given up for a bit and ask my fellow developers if there is something I have over looked.

Thank you for your help.

Regards,

Bob

Where did you buy the UNO from?

Radio Shack in the US.

[quote author=James C4S link=topic=144158.msg1082568#msg1082568 date=1358820504] Where did you buy the UNO from? [/quote]

Return for a new one. If the same problem persists, there is something up with your computer.

Problem solved. Bad USB cable. I finally tried it on another computer with the same result. Switched out the USB cable and.....

Cheers,

B