UNO rev3 no hardware detected

Hello , i have a problem when i connect the uno to the computer there is no new hardware recognized earlier i accidentlly shorted the ground and 5v pin but i know there is a fuse that disconnects the card until the shortage/load is cleared and this is what happend as i heard the windows usb disconnect then reconnect sound later this i tried uploading a sketch but i found no com port i tried disconnecting reconnecting but nothing happens no hardware found i tried on another computer but the same ? the atmega16u2 is fried ? or there is still hope , any suggestions solutions please share ? Thanks

i have another arduino Uno i uploaded arduinoISP sketch connected atmega16u2 ICSP header to the programmer used WinAvr and i write the firmware using this command

avrdude -p m16u2 -F -P COM12 -c avrisp -U flash:w:Arduino-usbserial-atmega16u2-Uno-Rev3.hex -U lfuse:w:0xFF:m -U hfuse:w:0xD9:m -U efuse:w:0xF4:m -U lock:w:0x0F:m -b 19200

and everything went smooth the new firmware was written , now i tried to connect the uno again but nothing happens no hardware detected obviously the atmega16u2 chip is not fried there is still hope .... if anyone could help me i suspect one of the components needs to be replaced a capacitor a transistor etc .... any tips or advice will be much appreciated thank you all