UNO stopped uploading

my UNO stopped uploading after several week of use. The error given is: avrdude: verifying ... avrdude: verification error, first mismatch at byte 0x0002 0x34 != 0x73 avrdude: verification error; content mismatch

I have found reports of similar errors but no solutions: what shall I do? It is not an hardware problem : I was simply reloading a sketch already run succesfully increasing the memory to reach the maximum without overflow. Now apparently ( from the comm window) a previous sketch (with memory overflow) keep running and resetting in an enddless loop. It is not possible to upload anything!! Can anybody help on this. Thank you Paolo

Remove everything from the board. Attempt to upload a sketch the blinks the LED on pin 13. Does that work?

I already tried to remove everything …no chanses…I cannot upload anything!!
I spent already several hours trying to understand…
…i beleive that fault coud be caused by previuos upload and by the fact that the application continously write to the comm and reset himself…
do you think that’s possible?
I have to find the way to remove this application , but I dont know how to do it: the only way I know is to upload onother one but I cannot do it!
Last chanse it is to buy another processor and to change it in the board…
but , there must be a SOFT way to solve this problem, (i hope)!

Thank you again

I attach the verbose output from the avrdude:
I noticed that fuses values are :0…
isnt very strange??

avrdude_out1.txt (12 KB)

I had this one myself on Windows 7 /64bits. It turned out that the com port (COM7 in my case) had disconnected itself and did not report that as such. Got only those cryptic message like yours. So there was no communication channel with the uno board. Just choosing the right port again fixed it for my situation.

Hope this helps..

I dont believe this is my case:

1- i can connect to arduino with the comm window and it show that the previous application run and reset(restart) in an endless loop. 2- to be sure that the PC was not causing the problem I have tried with another PC and a new installation of the IDE: i get exeactely the same error.

Thank you ....anyhow!


my UNO stopped uploading after several week of use.

It is possible, but not likely, you have burned up one of the flash cells and the ATmega can longer be programmed.

it show that the previous application run and reset(restart) in an endless loop.

Press and hold the RESET button on the Arduino, while starting the complie/upload process on the PC. When the "Sketch Size" message appears wait 1-2 seconds and release the RESET button. Try that a couple of times. You might also try holding down RESET before applying power to the Arduino.

I already tried all that several trial of pushing down th reset button during upload and during poweron . No way to overcome the problem.

I will try to upload trought an external programmer ( a second arduino uno with the avrisp application conneted to the ISP ).I hope this work ....I will let you know.


If ISP does not work, then you have probably burned out one of the flash cells in the chip. :-/

Finaly after reburning of the bootloader,I solved my problem. I can now upload, as usual, through the serial port. Fotunately there has not been any damage to the board and processor. It appear that the application I have loaded was looking the UNO: I strongly suggest that it become possible without reburning everithing the remove a locking application. One suggestion anyhow could be to alwais start with delay(5000) as first statement in setup() function to avoid this append again. Thank you for all yuor suggestions.


My Uno stopped uploading as well. I get a message like Paolo's: avrdude: verification error, first mismatch at byte 0x0000 0x0c != 0x00 avrdude: verification error; content mismatch

Everything was working very well till such time as I accidentally connected 9V to the 5V Uno output, although very briefly. Might I have damaged the two microcontrollers (ATMEGA8U2-MU and ATMEGA8) on my Uno board? According to their datasheets neither can tolerate > 6V on their supply pins.

I tried the reset-button trick that James suggested. I get the following message when I let go the reset button: avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51.

I wonder if I have irreversibly damaged my Uno. I could replace the ATMEGA8, the DIP chip, but I don’t think I even want to try replacing the ATMEGA8U2-MU (TQFP32).

Any suggestions would be most welcome.

Run a loop-back test...

  1. Disconnect power from the board

  2. Remove all connections and shields from the board

  3. Force the processor to remain in reset by connecting a jumper from RESET to GND

  4. Connect a jumper from the TX pin (1 on the Uno) to the RX pin (0 on the Uno)

  5. Connect the board to your computer. After a brief pause Windows will produce a device-insertion tone if sound is enabled. Linux may or may not produce a device-insertion tone; an entry is added to the system log.

  6. Start your favourite terminal application. Serial Monitor will work fine.

  7. Connect the terminal application to the serial port for your board. The baud rate is irrelevant.

  8. Send data by typing. Everything you type should be echoed back. To send data, some terminal applications, like Serial Monitor, require pressing the Enter key or clicking a Send button. If exactly what you send is echoed back then the board passes the test. This means that the host computer hardware driver, USB cable, and USB to serial converter are all working.

  9. Shutdown the terminal application

  10. Disconnect the board from the computer

  11. Remove the two jumpers