UNO Trouble uploading on XP ... not in sync/ protocol error

Hi, every body i m fighting to upload sketch to UNO from xp with arduino 0022 On my computer i was having 2 COM PORT showing up, despite only ONE arduino is connected I have made a clean of all my port com, using this : http://blog.cognitioninfotech.com/2009/01/how-to-clear-or-reset-com-port.html But i steel CANT upload any sketch; i have the following answer from compilator:

avrdude: stk500_getsync(): not in sync: resp=0x30 avrdyde: stk500_disable(): protocol error, expect=0x14, resp=0x51

I was before using a duemillanove without any troubles, and with FTDI drivers.

Other thing important: the UNO appears in Windows Hardware panel, with its comport, but there is NO communication between apps and the UNO The firmata exe doesnt shows up anything.

the UNO is alive and works well on another laptov with seven ( upload and job)

ANy solution ?

(deleted)

yes indeed. and i have only one COM PORT now showing up, selected.

I had this same problem, all I did was update the driver software, and also check in device manager (not sure what xp calls it), then ports, and from there you can change driver software and baud rate etc.. hope this helps.

driver software: is there one more recent than the one embedded inside arduino 0022 ?

(deleted)

this one: http://arduino.cc/en/uploads/Main/ArduinoUnoFront240.jpg

I have a friend that have the same problem on an XP with a duemillanove: works fine one one computer, not at all on the other. same troubles. we have in commun to use VCOM drivers from Enttec ( FTDI chipset) for dmx devices.

Hi, using the arduino 1 on mac os x 10.4.11 i have quite the same message: avrdude: stk500_getsync(): not in sync: resp=0x30 avrdyde: stk500_disable(): protocol error, expect=0x14, resp=0x51

i have the latest driver but.. no joy! :~

are you using other COM devices ( Enttec or FTDI products ) ?

i use this: FTDIUSBSerialDriver_10_4_10_5_10_6.mpkg and arduino 022

i think it's the best on mac os x 10.4.11 (ppc)

thanks

yiou are on UNO or DUEMILLANOVE ?

Is there any developper auround to help on this topic ?

hello

Arduino UNO uses the USB driver provided by Windows. The .inf file that you find in "drivers" is just telling windows "use your standard driver"

the FTDI driver should not interfere in any way.

make sure that the UNO shows up in Device Manager and has a COM port number assigned to it.

try reinstalling the driver and point windows to the "drivers" folder inside your Arduno folder.

Follow this guide http://arduino.cc/en/Guide/UnoDriversWindowsXP

it should work well.

Hi Massimo. First thanks for your reply and thanks for this great project that is arduino. Needs to be said, its great !

Coming back to myproblem, of course I have already followed this procedure. An I just retried just now, without any success. The UNO is selected in the IDE, and the COMPORT also

I still have them result:$Binary sketch size is printed and same trubles about sync and resp=0x30 protocol error: expected 0x14 resp 0x51 :fearful:

hum no idea on how to solve this or understand what s going up ?

(deleted)

hi! Done: 1-deleted the already existing RunOnce key 2-done creation of a new RunOnce Key then reboot i didnt killed the existing RunonceEx key 3-plugged the UNO driver still present > gone inside the device manager 4-uninstalled te driver 5-reinstalled it manually from the folder drivers in arduin0022 6-runed arduino 22 7-tried to upload a sketch with exactly same result: not in sync 0x30 protocol: 0x51 !

what can i do else ?

(deleted)

UNO_328.inf (2.24 KB)

hi spycatcher2k. helas, exactly same errors. impossible to laod any sketch inside ( tested with Blin)

the binary sketch size takes a long time if the sketch is bigger to appear. same answer: not in sync 0x30 protocol response 0x51 :drooling_face:

(deleted)