uno tx light on studdy ubuntu 10.04

hi
i have installed a couple of .pde's and it worked fine until the last time the arduino 0022 software when i was trying to up load a .pde had a java error and i didn't catch it, now the tx led stays on when it is connected to my computer and under tools serial port is grayed out and when i plug in the uno board the arduino 0022 soft ware becomes unresponsive. it was working one minute and not the next if i reset the uno board the led on pin 13 blinks three times but that is it , so i pulled out my duemilanove board and it worked fine on the same computer, same usb, cable same software and the same .pde program did my board go bad ? is there any fix? anything i can do ?

thank you in advance for any help

There's a firmware issue on early Uno boards that affects Linux, see here: http://arduino.cc/blog/2011/02/15/fix-to-uno-and-mega-2560-linux-serial-problems/

hi
thank you MarkTfor pointing me in the right direction.

this worked for me, i did have to load arduino 0022 on xp and load blink.pde to get rid of the problem after the upgrade