Uno w/ '328P-PU upload problem

I am using an Uno with atmega328P-PU on windows 7. Every time I try to upload I always get exactly the same error message (even on 2 different computers I've tried, both windows 7). This is the error message:

avrdude: verification error, first mismatch at byte 0x0000 0x0c != 0x00 avrdude: verification error; content mismatch

I have seen similar messages but none exactly the same, any help would be most welcome. Also I am fairly certain the bootloader is functional, as pressing the reset button causes the pin13 LED to blink. Power is fine (pwr LED on, using USB), and I am running it off the board so hopefully there aren't any circuitry problems. Strangely the board worked fine before, although in between working and breaking I put it on breadboard and tried to use Serial.read(). This shouldn't have effected it power was regulated 5V and also there is no serial traffic before uploading. The chip can't be burnt out as the reset LED blink still works, it seems to be a problem with uploading only. There doesn't seem to be a program running on the board either.

additional info: board: Uno chip: 328P-PU OS: windows 7 IDE: 0022 Code: "blink" example for testing COM port: 5 Drivers installed: yes (0022)

Thank you to anyone who can help.

(deleted)

Hi, yes they do blink, the chip is in the chip holder properly aswell. I just tried updating the driver although I did get the same error message, also in device manager the baud rate was listed as 9600 (arduino operates off 115200?) so I changed that, yet there seemed to be no effect.

Thanks anyway.

Can you post the verbose output of an upload? (Hold shift while clicking the upload button.)

Are you sure the chip is seated properly in the socket?

(deleted)

Make sure you have to correct board selected in the arduino software.