Uno wont load sketches (avrdude) trying to use Mega 2560 as ISP

Hi.. Well I cant say for sure but I think one night while playing with an RBG led I screwed something up. I was trying to load in a library, started screwing around, next thing I know Im getting the error avrdude: stk500_getsync(): not in sync: resp=0x00

Well I read every forum I could find, tried all the hold reset button tricks ( before and after ) but continue to get the error.

I purchased a Mega 2560 and have it loaded with the sketch to act as an ISP.. I followed the sparkfun tutorial (option 1) Installing an Arduino Bootloader - SparkFun Learn

when in avr dude im able run this command:

avrdude -P com7 -b 19200 -c avrisp -p m328p -v -e -U efuse:w
:0x05:m -U hfuse:w:0xD6:m -U lfuse:w:0xFF:m

to set the fuse bits but when I try to send the hex file I get this:

Writing | #################################################  | 98% 1.35s
avrdude: stk500_paged_write(): (a) protocol error, expect=0x14, resp=0x64
avrdude: stk500_cmd(): programmer is out of sync

Anyone out there willing to do a little troubleshooting?

heres the complete output

C:\uno> avrdude -P com7 -b 19200 -c avrisp -p m328p -v -e -U flash:w:optiboot_at
mega328.hex -U lock:w:0x0F:m

avrdude: Version 5.10, compiled on Jan 19 2010 at 10:45:23
         Copyright (c) 2000-2005 Brian Dean,
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "C:\WinAVR-20100110\bin\avrdude.conf"

         Using Port                    : com7
         Using Programmer              : avrisp
         Overriding Baud Rate          : 19200
         AVR Part                      : ATMEGA328P
         Chip Erase delay              : 9000 us
         PAGEL                         : PD7
         BS2                           : PC2
         RESET disposition             : dedicated
         RETRY pulse                   : SCK
         serial program mode           : yes
         parallel program mode         : yes
         Timeout                       : 200
         StabDelay                     : 100
         CmdexeDelay                   : 25
         SyncLoops                     : 32
         ByteDelay                     : 0
         PollIndex                     : 3
         PollValue                     : 0x53
         Memory Detail                 :

                                  Block Poll               Page
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  Max
W   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ---
-- ---------
           eeprom        65     5     4    0 no       1024    4      0  3600  36
00 0xff 0xff
           flash         65     6   128    0 yes     32768  128    256  4500  45
00 0xff 0xff
           lfuse          0     0     0    0 no          1    0      0  4500  45
00 0x00 0x00
           hfuse          0     0     0    0 no          1    0      0  4500  45
00 0x00 0x00
           efuse          0     0     0    0 no          1    0      0  4500  45
00 0x00 0x00
           lock           0     0     0    0 no          1    0      0  4500  45
00 0x00 0x00
           calibration    0     0     0    0 no          1    0      0     0
 0 0x00 0x00
           signature      0     0     0    0 no          3    0      0     0
 0 0x00 0x00

         Programmer Type : STK500
         Description     : Atmel AVR ISP
         Hardware Version: 2
         Firmware Version: 1.18
         Topcard         : Unknown
         Vtarget         : 0.0 V
         Varef           : 0.0 V
         Oscillator      : Off
         SCK period      : 0.1 us

avrdude: AVR device initialized and ready to accept instructions

And heres what I get when I try to burn it through the Arduino IDE

avrdude: stk500_paged_write(): (a) protocol error, expect=0x14, resp=0x64
avrdude: stk500_cmd(): programmer is out of sync

Why are you programming an Arduino board through an ISP?

The error message indicates that you have the wrong processor selected. What do you have selected as a board, and what do you have selected as ISP?

If you are running the ArduinoISP sketch you would want to select that as the programmer, and you have to select a board with the same processor as you are trying to program.

Also - Are you running the ArduinoISP sketch from Arduino-1.0 or from Arduino0.22? the sketch in 1.0 needs to be have teh serial speed changed (Serial.begin(9600) instead of (19200)) and teh serial speed changed in the AVRDude command.

expect=0x14, resp=0x64 would suggest that you have a 328 (the Ox14) not sure what 0x64 processor is.

you might try adding a -F in the command string so AVRDude will ignore the processor type.
avrdude -P com7 -b 19200 -c avrisp -p m328p -v -F -e -U efuse:w:0x05:m -U hfuse:w:0xD6:m -U lfuse:w:0xFF:m

Thanks for the reply. I have programmed my Arduino Mega 2560 R3 with the ArduinoISP sketch in Arduino IDE 1.0

The reason is that the UNO will not let me upload sketches directly to it. It powers up and has a steady light on 13. The reset button does not do anything. This all happened when I was messing with a library that was not compatible with Arduino 1.0 I think I may have reprogrammed the pin mapping... if thats possible?

Also I should note that while the documentation says to go from pin 13-13, 12-12, etc.. because Im using the Mega the MOSI and MISO are on ports 50-53 I believe.

I will try your suggestion but I believe I tried the -F and ended up with an out of sync 0x00 error..