Uno Works, Can't Bootload

Hey guys, really odd problem here. I have an Arduino Uno R3, brand-new, that functions but can't get new code over serial.

When I try to upload a sketch over USB, I get one of these errors:

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding

TX and RX LED's briefly flash. Occasionally, the L and/or TX LED's stay on.

The odd part is that the Arduino seems to be fully functioning. I can still upload sketches with ICSP, and UART over USB does work.

I tried using DFU to refresh the 16u2, burned fresh firmware on the 16u2 over ISP, burned new firmware on the Mega328 over ISP, and even pulled the Mega328 and replaced it with a known-working chip from another Arduino. No dice.

Any suggestions or troubleshooting tips?

Is anything connected to pins 0 and 1 (RX/TX) ?

I have the same error message (the 2nd one) when trying to upload to my Arduino Uno board. Was able to upload once and then keep getting error messages while uploading. Worked fine last time I tried it a week or more ago but not now.

I get the same error messages when trying to upload in each of the following ways:

  • Same code, different Arduino Uno board
  • Same code, different (both Mac running different OS versions) computer
  • Different code

The one thing that did work was using a PC. It was able to upload new code to the Arduino. The program was something which sent some text back to the computer via USB. Once that code was sent to the Arduino via the PC and was running on the Arduino, I plugged the Arduino back in to the Mac and the Mac was able to see the text the Arduino was sending over the USB cable. I hit the reset button on the Arduino board but nothing changed. While uploading from the Macs, a few red lights blink but not the usual blue ones. The Arduino keeps running the last code that was successfully uploaded. The Mac reports the upload error. I'm wondering if this affects all Macs?

Another thing, check the version of Java you are using. I was running into the exact same errors then I realized my system was running JDK_06 (which is my developemnt version). The IDE runs Open JDK 7. Be sure when running the IDE you are using the version of Java the IDE was shipped with.

On Ubuntu 13

$ java -version

if other than open-jdk-7…

$ sudo update-alternatives --config java

follow the prompt to switch the version