Unsuccessful install of IDE in Linux terminal app on Android tab A

Operated a Linux app (Termux) on a Samsung Android tablet (tab A).
The tablet has ARM processor(s), 64 bit, but running in 32 bit mode, according to another app (AIDA64)

Tried the Linux install procedures at https://www.arduino.cc/en/Guide/Linux with the following outcomes:

-1. Downloaded software. Downloaded all 4 [Linux] options, with with same install result in each instance. At least one forum discussion said downloading the wrong option caused operator troubles, so all 4 were tried, but no icon each time, and the same results below for each option.

-2. Extracted package with tar:
tar -xJf arduino-1.8.9-linuxarm.tar.xz The extraction processes reported the following, which was skipped over: tar: can't create hardlink 'arduino-1.8.9/hardware/tools/avr/bin/avr-gcc-5.4.0' to 'arduino-1.8.9/hardware/tools/avr/bin/avr-gcc' . 3.) Ran install script: ./install.sh

The script did complete quickly, but there were reports about a symbolic link, and no icon was observed on the “tablet’s desktop”. The reports were as follows:

Adding desktop shortcut and menu item for Arduino IDE…
rm: cannot remove ‘/usr/local/bin/arduino’: No such file or directory
Removing symlink failed. Hope that’s OK. If not then rerun as root with sudo.

ln: failed to create symbolic link ‘/usr/local/bin/arduino’: No such file or directory
Adding symlink failed. Hope that’s OK. If not then rerun as root with sudo.

One forum indicated the softlink error could be ignored (https://forum.arduino.cc/index.php?topic=610758.0). The Android does not do sudo the last I knew.
The tablet was restarted, but still no icon observed.

Research before posting
Another option to start the IDE by command line (./arduino) was found which resulted in the following report, but there was still no IDE window:
arduino: line 35: /data/data/com.termux/files/home/github/software/arduino/arduino-1.8.9/java/bin/java: No such file or directory

The file ‘java’, which the above script reported, was present. The list command ($ls -l) reported the following details for that file:
-rwx------ 1 u0_a146 u0_a146 5916 Oct 6 2018 java
Line 35 in the script (./arduino) was: "$JAVA" "${JAVA_OPTIONS[@]}" processing.app.Base "$@"

I manually browsed about 10 of the 1100 pages or so of the forum “Installation and Troubleshooting”. Because this was slow, I tried the forum’s advanced search on the same category, but did not see any results for the search terms ‘Android’ or ‘Termux’.

An icon was previously added to the tablet for a different program, someone else’s app (not arduino IDE) in the reference below. This was done in the same Linux app (Termux) on the Android tablet. I wouldn’t know if there are multiple ways to add the icons. The way It went for the other person’s app needed tools like aapt (android asset packaging tool), apksigner, ecj (eclipse compiler/java), etc. I’ll attach the script for that instance (00.txt), since it made an icon, but may not be at all relevant to IDE.
Reference: GitHub - jblough/bible-android: Basic King James Bible reading application for Android

Location: U.S.A., California, Lancaster

Signature: Greg

00.txt (3.09 KB)

I’ve never heard of anyone using the Arduino IDE on an Android device. I’d be very interesting to hear about someone who manages to accomplish this. There are some 3rd party solutions (something like andruino or ardudroid, I forget) but I think they’ll always be inferior to the official Arduino IDE. Although I feel that a real PC is the best tool for working with Arduino, I would like for it to be possible for people to use Arduino from any device they have available.

If you can’t get the Arduino IDE to work, it might be worth seeing if arduino-cli can be made to work:

Even if arduino-cli by itself doesn’t provide the experience you’re looking for, you might be able to use it in conjunction with an editor that is Android compatible.

Keep in mind that it’s not just about getting the Arduino IDE or arduino-cli to work. You also need the full toolchain for each board architecture you use to work. This means the compilation tools (like avr-gcc for the AVR boards like Uno) and the upload tools (like avrdude for the AVR boards).