Unusual problem: Sketch doesn't run after successfull upload...

First up, I am an experienced Arduino user and programmer, and computer user.

I am posting here to find out if anyone else has experienced problems with running more complex/advanced sketches uploaded from a WIN10 PC or laptop running a SoC cpu such as for example, an Intel N3540.

This is what I am experiencing:

A complex 'robotic control' sketch which loads and runs normally from standard WIN10 PC will not run when uploaded from a SoC computer. I click on the upload button and it loads normally, the on-board tx and rx leds activate and I get the 'Done uploading' message. I get no error messages.

Pressing the reset and/or opening the terminal monitor results in no response.

I have tried two different Soc PCs with a Nano, Mega and Due, with the same result.
I have checked that all 'drivers' etc... are up-to-date and working properly.

The SoC PCs will load and run simple Arduino sketches such as ; Blink, Fade and Get SD Card Info. Anything more complex will not run.

As yet, I have not tried a non usb board such as a Pro Mini with a FTDI.

Have I overlooked something really obvious... has anyone else experienced this?


You pretty much hit the nail on the head with SOC.

Are you running the APP version or the downloaded version of the IDE ?
The APP version can be a little problematic at the best of times.

Also think you may have to compile a version just for the SOC in use.


Thanks Bob, I'm running the downloaded Windows ver.