upgrade to 1.5.8 on RPi

Hello Everyone, I have a raspberry pi that I have installed the Arduino IDE on successfully. But I have a Arduino Yun which requires me to upgrade the IDE to 1.5.8. I downloaded and installed the Linux 32 bit version but it does not work - i ran the ./arduino.sh but got an error. I believe I have to download the 1.5.8 source code and package it to go on the PI. Would there be some easy steps to follow that would tell me how to do this in very basic terms.

Thanks