upgrading xbee serie 1

Hi everyone , please after a long discussion with DIGI about the problem i have with my xbee's serie 1 802.15.5 version 10EC, they answered e as above:


In order to perform a firmware upgrade, you need to have VCC, GND, DI, DO, RTS and DTR connected. I believe the Arduino Shields do not connect these lines from the PC to the XBee module. However you will want to verify that with the manufacture of the board in question. I think you will find that most 3rd party board will generally only connect Data in and Data out in addition to VCC and GND.

So anyone could help me with that o.O I didn't understand wthat should i do ? (i'm using arduino uno+xbee shield +xbee)

Thank you.

Which specific XBee shield do you have?

For the purpose of upgrading firmware (via X-CTU), I use one of these and one of these.

euuu xbee pro (designed by arduino and libellium). https://www.google.tn/search?q=xbee+shield+pro&source=lnms&tbm=isch&sa=X&ei=lWOBUc2EM8TMhAfRiIHACQ&ved=0CAoQ_AUoAQ&biw=1366&bih=643#imgrc=SdZ3r5lWqsoM5M%3A%3BFuYlvej-fZ2nOM%3Bhttp%253A%252F%252Fwww.matlog.com%252F181-818-thickbox%252Fxbee-shield-arduino.jpg%3Bhttp%253A%252F%252Fwww.matlog.com%252Fcalculateurs-microcontroleurs%252Fmicrocontroleurs-arduino%252Fxbee-shield-arduino.html%3B600%3B600

That link really doesn't help very much. However, if this is the device, then you can start to get somewheres, http://shieldlist.org/libelium/xbee http://www.libelium.com/squidbee/index.php?title=See_Schematics

The schematic shows DTR and RTS are not connected. You can read the datasheet to figure out how the DTR and RTS pins on the XBee module work, and then wire appropriate circuitry onto your shield to deal with this. It may require using 5V-to-3.3V level-shifters. You'll also have to figure out how to get the DTR and RTS signals from your computer, in addition to Tx,Rx.

The easiest thing to do is what Jack said.