Upload a sketch with browser (HEX file)

Hi all,

i have a few arduino Yun’s in the field connected with a 3G modem, i would like to
update my arduino code by uploading a HEX file trought the browser homepage;
nothing happens when i click ‘Upload’

I even tried this at home with my yun connected over cable to internet but the
upload doesn’t seem to start either. I select a correct HEX file, click upload but nothing
happens.

Am i doing something wrong here ? Is there another way ?

Hello,
what version of the Yun image are you using?

as far as i know it's 1.5.2

I see the most recent one is 1.5.3 . Did something change about the uploading
module ?

Anyhow, i was able to login in to the arduino wht WinSCP (a file manager) , upload
my hex file in the /tmp/ folder and run the following :

$/usr/bin/merge-sketch-with-bootloader.lua /tmp/myfile.hex
$/usr/bin/kill-bridge
$/usr/bin/run-avrdude /tmp/myfile.hex
$reboot

everything returned ok but now it seems that my yun didn't come back to live.
Maybe it needs to be plugged out from power to make it reboot properly, i had that
issue here before . Since the yun is a half hour drive away from here, i might
call the user to try that first. If not, i'm ready for a whole day driving around
updating yun's instead of doing it from my desk ; (which i intented to do!)

obviously, the reboot wasn't neccesary. Everything worked as soon as i uploaded my sketch ;D

So everything now works normally?