upload error avrdude: stk500_getsync():not in sync

All of a sudden I got a trouble of not being able to upload anything to my board. I'm completely new to the subject, so my google-search didn't bring me much success.

Well the matter is like this: I have an Arduino Duemilanove running on Mac Os X 10.4, software version 17, which was at first functioning alright. Yesterday when I was testing new sketches it stopped to work. I did too many things to be able to tell what influenced it. First I thought I did too many mistakes in the code, then since I noticed there was no more usb-port in the list I installed OS X PL2303 USB to Serial driver from Sourceforge. The port appeared in the list, after that in some while sketches stopped uploading. When I connect the board, the on-board power lights up, when I try to upload even Blink sketch, the LED in pin 13 blinks 3 times, then the on-board LED starts to blink very fast, almost glowing, but nothing happens. When in some while I press the button "upload" again the board replies "avrdude: stk500_getsync(): not in sync: resp=0x1e" or something similar.

I tried reinstalling the drivers, tried to connect the board to my PC running Windows, the result is the same. Could it be that I simply burned some part of it? I have no other board to try running here. I also had recently some Java-conflicts (supposedly), could it be the reason? IDE version 16 somehow doesn't even open after installation... What else can I do?

PS. OMG! Sorted out. The matter was wrong baud size.

I’m having the same problem. What baud rate did you use?

I got exactly the same problem until I cooled the board with a fan. Now the board (Mega) can be uploaded smoothly ! :)


I was getting the same sync message and ran through a bazillion forum messages. Then…SHAZAM!!!

While the silkscreen on the board says Arduino Duemilanove just like the ATMega328 I was working with prior to this new project, the client sent me a new board which uses the ATMega168 chip. Once I went to the Tools-Board menu and selected the right chip, things were warm and fuzzy again. It was a pure “flat forehead” mistake. (You know…where you hit the heel of your hand against your forehead and ask how you could be so stupid!)

Maybe this will help someone else who’s as dense as I am…

Greetings, This is my 1st post and I am new to Arduino. That said I have FIXED my sync problem and can reproduce error on my XP Pro laptop. So, the problem is that board is not communicating with the proper com port.

Open Hardware manager and find the PORTS (COM and LPT) click the plus +. Bottom item is shown is USB Serial port with a number; mine was port 5. Next step is open Properties for the port( rt click) and go to Port Settings. Make sure it is set to 38400. The defaults for the rest is AOK. Hope this helps.

I'm completely new to the subject, so my google-search didn't bring me much success.

Do you expect us to believe that you searched for "avrdude: stk500_getsync():not in sync" and you didn't get any relevant hits? Try this one (it's the one that comes up first out of over 12,000 hits at the US Google site): http://www.ladyada.net/learn/arduino/help.html.