Upload Error!

When I try to upload a piece of code to my Arduino it says:

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

I checked the troubleshoot pages and found nothing useful:

1 The Arduino is powered
2 I tried hitting the reset button right after pressing upload
3 I installed the drivers

What ever am I to do?

I also verified that the port I’m using is functional as well as the driver.

Which Arduino are you using? What operating system are you on?

I have the Diecimila and I'm using Windows XP.

Did you check that the COM port you’re using shows up as a USB-serial device in the Device Manager? Do you have any active firewalls or virus scanners?

I did check the port under the Device Manager and I do have a firewall (the one that was installed along with the Windows OS) I placed the Arduino.exe under the list of Exceptions to have it be able to access all ports.

Its Fixed! I'm very sorry to trouble anyone with this simple fix. For some reason or another, Com 1 was not working, so I went and tried all of them (like I should have before) and found Com 7 to work. Again I'm very sorry to waste anyones time with this silly question with a simple solution.