upload error

has any one had the following error and what is the solution?

Binary sketch size: 1018 bytes (of a 32256 byte maximum)
avrdude: stk500_getsync(): not in sync: resp=0x30
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

using a Dell Windows Vista

just purchased two Arduino Uno, my first. trying to get it going. just using the simple flashing led. compiles fine. won't upload to arduino. Please help.


usual stuff
have you installed the driver?

you may need to change the COM number - it doesn't like 3 or 4

What board are you using ?
check if you hva correctly selected the "board in "arduino" IDE
If it is duemilanove,
tools-> borad -> Duemilanove

I'm running a Uno under XP all was good then come to the same problem tried everything and finally stumbled on my fix. My Uno no longer runs as a Uno in the Tools / Board selection but as a Arduino Duemilanove or Nano w/ ATmega328. So when they say try everything, do so.

thank you for responses.

On Vista I only see com3, but I do see com1 on XP.

I am using the Uno board, but one response said there Uno actually won't work as Uno, but as the Duemilanove or Nano w/ ATmega328. I would never have tried that myself, but I will try that next.

Thanks much.

NO the UNO will run as UNO only because the main problem is the 8u2 CHip as it’s the fine substitute for the FTDi chip and thus the ATMEL 8u2 used in its place has been programmed to work as FTDi so the Arduino IDE needs conformation about the same board UNO to recognize it as 8u2 is all over different it is not just a the same FTDi you find over the Diecimilia or the Deumilanove.

So,Select the same board and install the driver file that it different from the previous arduino’s but like MEGA.

Nishant Sood