Upload from Linux Ubuntu Stopped Working

Hello, I just received my first Arduino yesterday. I had a Linux box running Ubuntu 12.04 ready and waiting. I had already installed the Arduino Software. If connected up, life was good. I uploaded, Blink, played with it, tried several things with it. I had it taking serial inputs for which LED to light up, then that program froze up, and since then I have not been able to upload anything. I then installed the arduino software on my windows 7 machine, it connected up, i uploaded blink just fine. Back to the linux box, and still no way to upload. Everytime I unplug and plug it back in it gets a different USB port that is one number higher.

I've tried resetting the arduino, restarting the linux box, and everything else I could think of, yet still no connection. Any help would be greatly appreciated.


There is/was a known issue with early Uno boards where the DFU firmware caused a problem with linux systems if a sketch using serial had been uploaded. It was sorted over a year ago but if you have an old board or its a clone still using outdated firmware it may be the issue.


OK I finally located what revision number I have, and it's already REV_0001 so I shouldn't be having that problem from what I can read.

The strange part is that even when I reset the arduino with a blink program using windows, my linux still will not talk to it.

What version of the IDE are you using? How was it installed?

I was using 1.0, I updated to 1.01, still doesn't work. It was installed through the ubuntu software center.

I was able to use the card just fine from a windows machine all, day, it's just linux that doesn't like it for some reason. The funny part is it worked great for several hours, now will not work at all.

Anybody have any thoughts on what I can try? I'm thinking I might have to try reinstalling linux from scratch and see if that helps, but even if it does, I'll be scared it will happen again.

Hi same problem here. The board was working good then after using serialwrite it stop. I bought two new arduino's and they also dont work, Funny thing is the first board worked fine for a wile. PLZ help.

I just did a fresh install of Ubuntu 12.04LT. I did nothing except run the updates (340 or so).

I installed IDE v1.0 from the Ubuntu repository. I did not even run it. I just wanted any upgrades to the libraries.

Then I went directly to the Arduino site and downloaded/unpacked IDE v1.0.1.

The install did not add the group "dialout" to my user, so the "Tools - Serial Port" selection was greyed out.


I added that group to my user, and all is well.

sudo usermod -aG dialout myusername

You must log out and log in again for the change to take.

I have compiled and uploaded both blink and a Serial.print() and Serial.write(), and I have not seen the fail yet. Is there something I should try to get it to fail?

edit: The IDE menu selections are very dark (dark blue). If you don't look close, it looks like they are missing. They are normal when you select one tho.

I was running a program with a serial.print command, that also was reading from the serial port. It was working well, then it hung up, and since then I cannot connect even to run a standard blink program. Yet I can connect to a windows machine and it works great.

I noticed the IDE menu items are hard to see, but they are there, and I can access them, just as soon as I try to upload, the serial connection fails, and I lose the USB port from the serial port menu. If it is listed as ttyACM0 when I first try and it fails, then if I disconnect and reconnect it will show up as ttyACM2, but it will again fail when I try an upload.

Is your user a member of group "dialout"? From a terminal:


There should be several groups listed, and dialout must be one of them to access the Arduino.

Ok, I checked, and dialout is one of the groups my user belongs too.

I can't reproduce the error. If you post the sketch code that locked up the code on your Ubuntu box, that might help.

edit: Maybe your preferences.txt file is corrupt. In your home directory, there should be a directory named .arduino (hidden). In that directory is a preferences.txt file. Try renaming that file to preferences.old, and restart the IDE. It will prompt for a sketch folder, and I selected "sketchbook" and all worked fine. You must select the board and serial port again before you can upload anything.

I installed arduino on my lap top running ubuntu 12.04 . It worked fine until i uploaded serial event connected to a gps , open serial monitor it worked. When i close serial monitor and try to upload a new program it stopped working. I did all of the above and a lot more can not get it to work again.

@dvlaudio: Are you using IDE v1.0.1 from the Arduino site? Can you upload a sketch using Windows also?

Yes . I do not have windows ,but from a different pc running ubuntu 10.04 it still works , to afraid to upload more than blink.

I've been trying different example sketches today with IDE v1.0.1 and Ubuntu 12.04, and can't get it to fail. I have been using Ubuntu 11.10 for a few months with no problems there.

The only thing I can recommend now is checking the permissions on the Arduino usb. From a terminal

cd /dev
ls -l ttyACM*

Here is mine:

tim@tim-desktop:/dev$ ls -l ttyACM* crw-rw---- 1 root dialout 166, 0 Aug 1 05:46 ttyACM0

here is mine crw-rw---- 1 root dialout 166, 0 2012-08-01 15:08 ttyACM0 booysen@booysen-desktop:/dev$

That is Ubuntu 12.04? Why is your device last access date a different format than mine? I'll play with that a bit.

The first one is from my pc this is from laptop. jacques@jacques-HP-Pavilion-dv6-Notebook-PC:/dev$ ls -l ttyACM* crw-rw---- 1 root dialout 166, 0 Aug 1 15:18 ttyACM0

I have one pc left running on 10.04 that it is still working on.