Upload inpossible - Burn Bootloader

messieurs,

Je rencontres un pb avec ma carte arduino duemilanove.

Je ne peux plus Uploader des programmes sur la carte, systematiquement ce message apparait:

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

Etat des lieux de fonctionnement:

Lors de la mise sous tension via USB, led led verte d'alimentation est alimenté, et la led rouge (symbole L ) ne cesse de clignoter ( comme si le programme blink de la bibliotheque etant en marche ), les leds Rx-Tx clignote brievement au debut puis s'arrete completement.

D'apres plusieurs forums cela peut venir de n'importe quoi, donc apres réinstallation complete de Arduino022 et du driver FTDI, aucunes ameliorations.

Par contre il est fort possible que j'ai effectuer une mauvaise manipulation en cliquant sur Burn Bootloader.

Etant en cours de test sur mon projet MultiWiicopter, pourriez-vous venir à mon aide rapidement que je finalise le test de la WM+.

Merci d'avance.

Bonjour,

sundgau68:
la led rouge (symbole L ) ne cesse de clignoter ( comme si le programme blink de la bibliothèque était en marche ), les leds Rx-Tx clignote brièvement au début puis s'arrête complètement.
(...)
Par contre il est fort possible que j'ai effectuer une mauvaise manipulation en cliquant sur Burn Bootloader.

Cherche pas plus loin, c'est au niveau du bootloader.
Est ce que ton dernier sketch utilisé les broches 0 & 1 en digital ? Ou est ce qu'il faisait une utilisation importante du port série ?

Si oui, avec un petite manip tu devrait pouvoir débloquer ton arduino, si non il faudra une autre carte arduino pour reprogrammer la 1er ou utiliser la puce FTDI (usb) en mode bit-bang pour reprogrammer l'ATmega328 de ta carte.

J'etais en cours de test pour verifier le fonctionnement et la connection entre l'arduino et le WM+.

Il me semble donc que le test est justement l'envoi et la reception d'information en continue pour déterminé et corriger la position du drone.

Il est fort possible que j'ai utilisé les bornes D0(RX) et D1(TX).

Pourrais tu m'indiquer la manipulation à réaliser pour reinitialiser l'arduino.

Bon apres approffondissement dans le but de trouver une solution, soit acheter une nouvelle Eprom pré-programmer OU demander à une âme charitable de bien vouloir remettre le bootloader dans mon Eprom.

Je fais donc appel à votre bon coeur messieur-dame....sniff

sundgau68:
Bon apres approffondissement dans le but de trouver une solution, soit acheter une nouvelle Eprom pré-programmer OU demander à une âme charitable de bien vouloir remettre le bootloader dans mon Eprom.

Heu Eprom ? C'est un microcontrolleur l'ATmega328 c'est de la flash pour le stockage du programme + bootloader.

La procédure de déblocage (à faire de préférence sous windows, le driver FTDI sous windows met plusse de temps à réagir) :

  • Lancer l'exemple blink sur l'ide arduino,
  • brancher la carte, sélectionner le port série qui va bien dans l'ide et le bon type de carte,
  • appuyer sur le bouton reset ET LE GARDER appuyé,
  • lancer en parallèle l'upload sur l'ide arduino,
  • quand la ligne "binary done ..." s'affiche attendre une seconde puis relâcher le bouton reset,
    si ça rate refaire les 3 étapes précédentes, et si ça marche vraiment pas :
    http://www.geocities.jp/arduino_diecimila/bootloader/index_en.html

Bonjour à tous,

Méthode qui fonctionne bien:

Maintenez enfoncé le bouton Reset.
Débranchez le câble USB.
Branchez le câble USB.
Ouvrir Fichier/Examples/Basics/BarreMinimum dans la fenêtre arduino et upload.
Quand vous voyez "taille croquis binaire:" dans la fenêtre d'esquisse, relâchez le bouton de réinitialisation.

Merci a vous pour ces deux methodes pour bootloader.

je ne peux pas essayer la premiere methode je ne suis pas equiper pour l'instant en connetique adapter.

La seconde methode fait toutjours apparaitre le message d'erreur suivant:

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

Par contre la veille j'avais egalement tester mon shield ethernet que je venais de recevoir. J'ai juste debrancher le shield ethernet le lendemain matin pour tester les capteurs WM+ sur l'arduino.

J'ai vu sur ce site:http://www.geocities.jp/arduino_diecimila/bootloader/index_en.html que les connecteurs X3 et ICSP etaient relier ensemble comme sur la carte ethernet.

Peut il y avoir un lien ? je vais essayer ce soir de remettre la shield ethernet en place sur l'arduino et de recharger un soft dans l'arduino voir si il accepte.

Salut,

Tu peux très bien essayé la méthode de Skywodd puisqu’il ne faut… Que ta platine Arduino.

bon alors essai de mise en place bootloader avec avrdude-GUI.

L'installation soft c'est ok, celui-ci demarre, sueleuement lorsque je laisse l'action READ j'obtiens un message d'erreur dans une fenetre avrdud-GUI: avrdude.exe: ft0 open failed

Je supposes que cela vient de la commande a inscrire dans la fenetre "Command line Option" à savoir "-P ft0 -B 4800"

Que dois-je faire?

Je penses savoir d'ou vient le probleme d'upload impossible de programme.

Ayant fait des test hier soir avec mon nouveau shield ethernet avec une version identique a celle-ci (http://www.watterott.com/en/blog/Upload-problem-with-Ethernet-Shield) il est expliquer dans la notice que dexu resistances presentes sur le shield ethernet bloque l'upload de programmes dans l'arduino et qu'il faut tout simplement les enlever pour regler le probleme.

Voir post:Arduino Forum

Je frais donc un essai ce soir et vous tiendrais au courant.

Je me suis tromper ce n'est pas la meme version de platine ethernet.

Voici le modele que je possede: http://boutique.semageek.com/fr/shields/5-shield-ethernet-blindage-arduino.html

Donc je reste ouvert a toute aide bien cordialement

Nouvelle essai:

J'ai brancher le RESET au GND, et TX à RX lancer un test d'upload fichier et voici le nouveau message d'erreur que j'obtiens.

Binary sketch size: 3036 bytes (of a 30720 byte maximum)
C:\Programme\arduino-0021\hardware/tools/avr/bin/avrdude -CC:\Programme\arduino-0021\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega328p -cstk500v1 -P\.\COM1 -b57600 -D -Uflash:w:C:\DOKUME~1\poutot\LOKALE~1\Temp\build4863711160478960768.tmp\Knock.cpp.hex:i

avrdude: Version 5.4-arduino, compiled on Oct 11 2007 at 19:12:32
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

System wide configuration file is "C:\Programme\arduino-0021\hardware/tools/avr/etc/avrdude.conf"

Using Port : \.\COM1
Using Programmer : stk500v1
Overriding Baud Rate : 57600
avrdude: ser_open(): setting dtr
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: Send: Q [51] [20]
avrdude: Recv:
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

avrdude done. Thank you.

Il me semble avoir deja croisé celui-ci sur un post

Bonjour,

Tu devrais déjà mettre ta version à jour. 0021 vers 0022.

Installation de arduino-0022 avec ajout du texte "upload.verbose=true" dans le fichiers preferences.txt.

mais aucun changement, meme en essayant la manipulation de maintenir le bouton RESET appuyer jusqu'a l'apparition de

Using Port : \.\COM1
Using Programmer : stk500v1
Overriding Baud Rate : 57600
avrdude: ser_open(): setting dtr
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]

sniff, je desespere de pouvoir m'en sortir

Essai de changer le numéro de com, passe le en com5 à9600bauds et recommence le reset avec ta platine nu sans les cablages externe.