Upload issue (verification error)

Hello guys,

First of all o have to apologize 1/ for my bad english 2/ for a recurrent post;
I know I’m not the first one but I dot find any simple answer to my issue…
(and YES I’ve read trouble shouting before posting ;o)

A - My issue (when upload):
<<
avrdude: verification error, first mismatch at byte 0x0000
0x0c != 0xff
avrdude: verification error; content mismatch

This error occurs since this morning. The board worked fine during last days
(the board was fully disconnected from my computer and reconnected to another computer and worked “once” on the other computer. That means “one” upload succeeded. Then the error occured after a tiny modification in my own code.
So I tried the “blink” sample just to be sure it was not my code that was at the origin of the problem.

I also have a second board (spare one) that works FINE. So, the problem is really on the board (Sounds obvious, right ?).

B - My configuration:

  • Original Arduino UNO rev 3
  • Mac OS X.7.5 (also tried on Mac OS X.9.1, same issue)
  • Arduino software Version 1.0.5
    Menu settings :
  • Tool / Board/ → Arduino Uno
  • Tool / Serial Port → /dev/tty.usbmodem1d11

C - The facts :

On the board,

  • the L13 led is “on”
  • the L13 led blinks on hard reset
  • the TxRx leds blinks when triing to upload (before the error occurs)

I have activated the “verbose option” in the preferences for the upload and here is the “log” (sorry it’s LONG So i will NOT post it unless requested)

BTW when I press shift (as requested in “read me first”) here is what i get :

avrdude: Version 5.11, compiled on Sep 2 2011 at 18:52:52

  • Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/*
  • Copyright (c) 2007-2009 Joerg Wunsch*
  • System wide configuration file is “/Applications/Arduino-1.0.5.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf”*
  • User configuration file is “/Volumes/TerraOne/Users/roland/.avrduderc”*
  • User configuration file does not exist or is not a regular file, skipping*
  • Using Port : usb*
  • Using Programmer : stk500v2*
    avrdude: usbdev_open(): did not find any USB device “usb” <<< *** this sounds strange to me ***

D - I’ve tried the “loopback” test

(which is not described for Mac, only for PCs but… quite the same stuff i guess) and it seems to work except i don’t get back the string I sent (but both leds blinks and i got somethig back)

Exemple “ABCDE” returns “P¨èTô” when using 14400 bauds, returns “P¨(Tô” at 19200 bauds, etc. I’ve tried every values of the serial monitor but none of them succeeded sending back the same string.

E - Thank’s for reading and thank’s to anyone that can help… ;o)))

Roland, Paris, France

(email : roland - at - lannuzel - dot - net)