upload not working

So i am improving an ender 3. The upgrades I am making are a MKS Gen L board, a bltouch, the TFT Wifi add on, and a TFT32 touch display also mks. the drivers are A4990 and I have hit a dead end. my sketch will not upload for some reason and the tft spazzes out. please any help is appreciated. I cant get anything please help, I am attaching the 3 main files

Configuration.h (72.4 KB)

Configuration_adv.h (68.9 KB)

mks_config.txt (6.15 KB)

So i am improving an ender 3. The upgrades I am making are a MKS Gen L board, a bltouch, the TFT Wifi add on, and a TFT32 touch display also mks. the drivers are A4990 and I have hit a dead end. my sketch will not upload for some reason and the tft spazzes out. please any help is appreciated. I cant get anything please help, I am attaching the 3 main files. I know this task is way out of my league.

:disappointed_relieved: :disappointed_relieved: :disappointed_relieved:

mks_config.txt (6.15 KB)

Configuration_adv.h (68.9 KB)

Configuration.h (72.4 KB)

@StonerBoy, please do not cross-post. Threads merged.

Please do this:

  • When you encounter an error, you’ll see a button on the right side of the orange bar “Copy error messages” in the Arduino IDE (or the icon that looks like two pieces of paper at the top right corner of the black console window in the Arduino Web Editor). Click that button…
  • In a forum reply here, click on the reply field.
  • Click the </> button on the forum toolbar. This will add the forum’s code tags markup to your reply.
  • Press “Ctrl + V”. This will paste the error between the code tags.
  • Move the cursor outside of the code tags before you add any additional text to your reply.

If the text exceeds the forum’s 9000 character limit, save it to a .txt file and post it as an attachment. If you click the “Reply” button here, you will see an “Attachments and other settings” link.

Alright here it is I have no idea why it will not work only orange text is that bottom stuff.

error1.txt (215 KB)

The relevant part of StonerBoy's output:

C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.21.0_x86__mdqgnx93n4wtt\hardware\tools\avr/bin/avrdude -CC:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.21.0_x86__mdqgnx93n4wtt\hardware\tools\avr/etc/avrdude.conf -v -patmega2560 -cwiring -PCOM3 -b115200 -D -Uflash:w:C:\Users\Nus\AppData\Local\Temp\arduino_build_327654/Marlin.ino.hex:i 

avrdude: Version 6.3-20171130
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.21.0_x86__mdqgnx93n4wtt\hardware\tools\avr/etc/avrdude.conf"

         Using Port                    : COM3
         Using Programmer              : wiring
         Overriding Baud Rate          : 115200
An error occurred while uploading the sketch

That is not very helpful. Normally avrdude will give some nice error messages that explain what went wrong, but in this case everything is looking fine until the process fails.

Please try this:

  • File > New
  • Sketch > Upload

Does the upload finish successfully?

Ok sorry it took a while I did it but an error occurred again here is the error code (I cut out some stuff)

Arduino: 1.8.9 (Windows Store 1.8.21.0) (Windows 10), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.21.0_x86__mdqgnx93n4wtt\arduino-builder -dump-prefs -logger=machine -hardware C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.21.0_x86__mdqgnx93n4wtt\hardware -tools C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.21.0_x86__mdqgnx93n4wtt\tools-builder -tools C:\Program 
Linking everything together...
"C:\\Program Files\\WindowsApps\\ArduinoLLC.ArduinoIDE_1.8.21.0_x86__mdqgnx93n4wtt\\hardware\\tools\\avr/bin/avr-gcc" -Wall -Wextra -Os -g -flto -fuse-linker-plugin -Wl,--gc-sections,--relax -mmcu=atmega2560 -o "C:\\Users\\Nus\\AppData\\Local\\Temp\\arduino_build_15740/sketch_jul06a.ino.elf" "C:\\Users\\Nus\\AppData\\Local\\Temp\\arduino_build_15740\\sketch\\sketch_jul06a.ino.cpp.o" "C:\\Users\\Nus\\AppData\\Local\\Temp\\arduino_build_15740/..\\arduino_cache_342725\\core\\core_arduino_avr_mega_cpu_atmega2560_180a539c02cce575fcd7710170113f75.a" "-LC:\\Users\\Nus\\AppData\\Local\\Temp\\arduino_build_15740" -lm
"C:\\Program Files\\WindowsApps\\ArduinoLLC.ArduinoIDE_1.8.21.0_x86__mdqgnx93n4wtt\\hardware\\tools\\avr/bin/avr-objcopy" -O ihex -j .eeprom --set-section-flags=.eeprom=alloc,load --no-change-warnings --change-section-lma .eeprom=0 "C:\\Users\\Nus\\AppData\\Local\\Temp\\arduino_build_15740/sketch_jul06a.ino.elf" "C:\\Users\\Nus\\AppData\\Local\\Temp\\arduino_build_15740/sketch_jul06a.ino.eep"
"C:\\Program Files\\WindowsApps\\ArduinoLLC.ArduinoIDE_1.8.21.0_x86__mdqgnx93n4wtt\\hardware\\tools\\avr/bin/avr-objcopy" -O ihex -R .eeprom "C:\\Users\\Nus\\AppData\\Local\\Temp\\arduino_build_15740/sketch_jul06a.ino.elf" "C:\\Users\\Nus\\AppData\\Local\\Temp\\arduino_build_15740/sketch_jul06a.ino.hex"
"C:\\Program Files\\WindowsApps\\ArduinoLLC.ArduinoIDE_1.8.21.0_x86__mdqgnx93n4wtt\\hardware\\tools\\avr/bin/avr-size" -A "C:\\Users\\Nus\\AppData\\Local\\Temp\\arduino_build_15740/sketch_jul06a.ino.elf"
Sketch uses 656 bytes (0%) of program storage space. Maximum is 253952 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 8183 bytes for local variables. Maximum is 8192 bytes.
C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.21.0_x86__mdqgnx93n4wtt\hardware\tools\avr/bin/avrdude -CC:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.21.0_x86__mdqgnx93n4wtt\hardware\tools\avr/etc/avrdude.conf -v -patmega2560 -cwiring -PCOM3 -b115200 -D -Uflash:w:C:\Users\Nus\AppData\Local\Temp\arduino_build_15740/sketch_jul06a.ino.hex:i 

avrdude: Version 6.3-20171130
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.21.0_x86__mdqgnx93n4wtt\hardware\tools\avr/etc/avrdude.conf"

         Using Port                    : COM3
         Using Programmer              : wiring
         Overriding Baud Rate          : 115200
An error occurred while uploading the sketch