upload prob Ard.1Side parall. ext. prog. 1st use

Hi, this is my first post, sorry if its messy or much common ;) I've made an arduino single sidet : http://www.arduino.cc/en/Main/ArduinoBoardSerialSingleSided3

And can't put it to live - can't upload codes, I'm trying to programme the chip without the bootloader actualy I whas trying to uplad the bootloader which I got from :

http://svn.berlios.de/viewcvs/arduino/trunk/hardware/bootloaders/atmega8/?rev=463

but still got nothing gud... I allso modified the preferences txt :

uopload.using=parallel

serial.debug_rate=9600

and now I keap getting an err. like :

Binary sketch size: 860 bytes (of a 7168 byte maximum)

avrdude: can't open device "giveio" avrdude: failed to open parallel port "lpt1"


I;m using :

ATMEGA8-16PU external programmer parallel cable powering through usb-dc adapter cable I cheked the cable connection - all is right

-- curently using the Arduino0011

Stable Library

NAtive lib Version = RXTX-2.1-7 Java lib vertion = RXTX-2.1-7

Binary scech size 860 bytes (of a7168byte maximum)

boud rate : 9600

please can enny one lead me on the right track, thanKs a Bigg :)

Hi.

first:
you said:
“powering through usb-dc adapter cable”
how are you connecting the usb-dc adapter cable? Is the power led lit?
if you are connecting the adapter to the DC jack it will not work. The voltage regulator needs at last 7volts.
But you can connect the adapter directly to the +5v. pin and to gnd pin on Arduino.

second:
if you’re using the parallel port programmer (http://www.arduino.cc/en/Hacking/ParallelProgrammer)
I think you need to install giveio before. You’ll find this link (http://web.mit.edu/6.115/www/miscfiles/giveio.zip) at the end of the parallel port programer page.
If you’re using WindowsXP, this would be necessary:
http://www.melabs.com/downloads/XP_stop_polling.reg
More info here: http://www.arduino.cc/en/Hacking/Bootloader

third:
if you want to upload sketches without using the bootloader, be sure the changes you’ve made on preferences.txt file was correct. Your post says:
uopload.using=parallel
and the correct is:
upload.using=parallel

If your Atmega IC was empty (i.e. you never burned the bootloader on it), you must change the fuses on it to make it work fine. If you’re not an expert, I think the easiest way to do it is burning the bootloader. But you can use the IDE0011 bootloader, with the parallel port programmer.
You must select the board type on IDE: tools/board/arduino NG or older w/ atmega8
Then, select tools/burn bootloader/w/ parallel programmer.

Before burned the bootloader, you can upload sketches through serial cable (using the bootloader - remember to change upload.using=bootloader on preferences.txt) or upload sketches using the parallel port programmer (not using the bootloader already recorded on it - remember to change the upload.using=parallel on preferences.txt)

Hello, thank's fore the help I realy aprescheate it :)

so,

powering through usb-dc adapter cable

its a simple DIY cable, I've got usb pin cofigurations from here:

http://en.wikipedia.org/wiki/USB

And her's the picture:

but its strange, couse when I first connected it the power led whas very weack, but right after Iconnected the parallel only the "L" led lit, and when I tried to connect both, the both leds lit normal. but here next, after I connected only the "usb" the power led whas still normal ... spookie and when I connected with the giveio the and tried to uplod, than both "L" and power leds binked rappidly and the power led whas weak agein

and so I installed the giveio than the "L" led showed first interaction... but I got the message " AVR device not responding..." and a suggestion above to sellect the right board ( I know the right one is arduino NG or older w/ atmega8 . I tried all of them and got the same)...

p.s. I cheked the pref. txt. file all in youre intructions whas rihgt, thanks again :)

vldo, Your picture confirms what Adilson said. You can not plug the USB into the power jack. You need at least about 7V into the power jack. (You can use USB to power the Arduino by connecting the positive to the +5V pin and the Gnd to Gnd as he also mentioned.)

Because your voltage is now too low, strange things will happen. So first fix your power and then see how things work.

vldo,

Brohogan is correct.
Your usb cable cannot feed the arduino through DC jack.
It’s necessary more than 7 volts to feed arduino using DCjack, or 5volts to feed arduino through 5v/gnd pins.

but its strange, couse when I first connected it the power led whas very weack, but right after Iconnected the parallel only the “L” led lit, and when I tried to connect both, the both leds lit normal. but here next, after I connected only the “usb” the power led whas still normal … spookie
and when I connected with the giveio the and tried to uplod, than both “L” and power leds binked rappidly and the power led whas weak agein

The power led will lit weakly because your DC voltage from usb is too low.
The L led, and the power led are affected by the parallel port programmer (PPP), that’s why they lit a little when the PPP is connected.
Fix your DC power problem, and try again.

But don’t forget to put the jumpers in your board, like in this picture:

Ok, I fixed the powering problem (5v & gnd pins) - no more spookie leds.. and made the jumpers, just like in the picture. Then tried to upload the : open/examples/digital/blink and again, got the same message :

Binary sketch size: 860 bytes (of a 7168 byte maximum)

avrdude: AVR device not responding avrdude: initialization failed, rc=-1 avrdude: Yikes! Invalid device signature. avrdude: Expected signature for ATMEGA8 is 1E 93 07 avrdude: AVR device not responding avrdude: verification error, first mismatch at byte 0x0000 0x38 != 0xff avrdude: verification error; content mismatch

sorry fore the bad grammar, english is not my natyve :-P and thank's (-;

Your computer seems to be communicating with arduino now.

Did you set the fuses properly? Or burned the bootloader - like I said on first post (doing this will set the fuses correctly too)?

If your Atmega IC was empty (i.e. you never burned the bootloader on it), you must change the fuses on it to make it work fine. If you’re not an expert, I think the easiest way to do it is burning the bootloader. But you can use the IDE0011 bootloader, with the parallel port programmer.
You must select the board type on IDE: tools/board/arduino NG or older w/ atmega8
Then, select tools/burn bootloader/w/ parallel programmer.

If you have tryed and did not succeed, you can try the DOS alternative (if using DOS or Windows):
Run this:
C:<your directory>\arduino-0011-win\arduino-0011\hardware\tools\avr\bin\avrdude -CC:<your directory>\arduino-0011-win\arduino-0011\hardware\tools\avr\etc\avrdude.conf -v -v -v -v -pm8 -cdapa -e -Ulock:w:0xFF:m -Uhfuse:w:0xca:m -Ulfuse:w:0xdf:m -F -b115200

And don’t worry about the english. It’s not my native language too. :stuck_out_tongue:

Hellow Adilson,
I whas away fore some days…
whell, but her’s what I did :
Iv’e tried to load your’e instruction in the windows “command line” (I’m using win xp sp2 prof) just by dropping the “avrdude.exe” in to it, pres anter, and got a lot of values… Than I tried many ways to open the “avrdude.conf”
and finely did this with the “word pad”, but I did’nt know how to modifie it…
So I’ve triet to load the bootloader from the “0007” IDE and got this long message below…
but uploading the skech, all whas the same again.
So, I tried to load it from the “0007” and the “0011” IDE’s,
than to change the boud rate to 9600, allso setting from the parallel to the bootloader
in pref. txt. of the “0011” and loadd with serial… and nothing helped - all errorrs still the same (“device not rsponding…” “avrdude arror…” and so on) :frowning:

p.s. the parameters in the message seam to be similar as in your last post :

qoute from : Adilson Akashi 11.07.2008 at 01:31:03

C:<your directory>\arduino-0011-win\arduino-0011\hardware\tools\avr\bin\avrdude -CC:<your directory>\arduino-0011-win\arduino-0011\hardware\tools\avr\etc\avrdude.conf -v -v -v -v -pm8 -cdapa -e -Ulock:w:0xFF:m -Uhfuse:w:0xca:m -Ulfuse:w:0xdf:m -F -b115200

but there’s a lot of flash errors, and what if that means that, my atmega is ded ?
anny way, all buy a new one to day and trie it again

Atmel AVR ATmega8 is found.
Writing lock bits ...
Reinitializing device
Atmel AVR ATmega8 is found.

Lock Bits set to 0xff
Atmel AVR ATmega8 is found.

Fuse Low Byte set to 0xdf

Fuse High Byte set to 0xca
Atmel AVR ATmega8 is found.
Erasing device ...
Reinitializing device
Atmel AVR ATmega8 is found.
Uploading: flash
Verifying: flash
flash error at address 0x1c00: file=0x12, mem=0x00
flash error at address 0x1c01: file=0xc0, mem=0x7f
flash error at address 0x1c02: file=0x2b, mem=0x01
flash error at address 0x1c03: file=0xc0, mem=0xff
flash error at address 0x1c04: file=0x2a, mem=0x00
flash error at address 0x1c05: file=0xc0, mem=0x02

... ... and so on ... ...

flash error at address 0x1fe8: file=0x80, mem=0xf4
flash error at address 0x1fe9: file=0x00, mem=0xf4
Atmel AVR ATmega8 is found.
Writing lock bits ...
Reinitializing device
Atmel AVR ATmega8 is found.

Lock Bits set to 0xcf

Thak's for the coffie and see you :)

Hellow Adilson,
whell, but her’s what I did :
Iv’e tried to load your’e instruction in the windows “command line” (I’m using win xp sp2 prof) just by dropping the “avrdude.exe” in to it, pres anter, and got a lot of values… Than I tried many ways to open the “avrdude.conf”
and finely did this with the “word pad”, but I did’nt know how to modifie it…

On my suggestion on use the command line, is supposed that you write the full command on DOS prompt:

C:\<your directory>\arduino-0011-win\arduino-0011\hardware\tools\avr\bin\avrdude -CC:\<your directory>\arduino-0011-win\arduino-0011\hardware\tools\avr\etc\avrdude.conf -v -v -v -v -pm8 -cdapa -e -Ulock:w:0xFF:m -Uhfuse:w:0xca:m -Ulfuse:w:0xdf:m -F -b115200

Changing only the content of .
You don’t have/need to open avrdude.conf file.

Hi,
ok I think I finaly got it right in the DOS prompt, just earlier I whas trying to type it but I think I whas making mistakes. Enny way, now when I tiped it right, than pressed enter and nothing happenned.
After I tryied to upload sumthing, all whas the same again

and that’s how it looked like in the DOS prompt :

Microsoft<R> Windows DOS
<C>Copyright Microsoft Corp 1990-2001.

C:\WINDOWS\SYSTEM32>C:\Program Files\arduino-0011-win\arduino-0011\hardware\tools\avr\bin\avrdude -CC:\Program Files\arduino-0011-win\arduino-0011\

C:\WINDOWS\SYSTEM32>hardware\tools\avr\etc\avrdude.conf -v -v -v -v -pm8 -cdapa -e -Ulock:w:0xFF:m -Uhfuse:w:0xca:m -Ulfuse:w:0xdf:m -F -b115200 

C:\WINDOWS\SYSTEM32>_

thank’s fore the help realy, I think some day I’m gonna get it (-:

Vldo,
you know, this is only necessary because to burn the bootloader using IDE is not working for you.

But I think you are making mistakes yet.

Look:
When clicking Start/Programs/Acessories/DOS Prompt, the black window will show you this:

C:\>

or some other prompt, like this:

C:\WINDOWS\>

Then, you must type (or copy/paste**) the FULL line command, in ONE Dos Prompt line:

C:\Program Files\arduino-0011-win\arduino-0011\hardware\tools\avr\bin\avrdude -CC:\Program Files\arduino-0011-win\arduino-0011\hardware\tools\avr\etc\avrdude.conf -v -v -v -v -pm8 -cdapa -e -Ulock:w:0xFF:m -Uhfuse:w:0xca:m -Ulfuse:w:0xdf:m -F -b115200

Then Press

Your mistake was typing the command line divided in TWO Dos Prompt lines. That’s why it didn’t work.

** to copy (the command line above) you can select all line and use CTRL+C or click with the mouse right button. But to paste inside the DOS Prompt black box, the CTRL+V will not work. You must use the mouse right button, to select “paste”.

Hi :-),

after a long time I met a gud friend of myne, and he made me a pressent. A BASIC stamp "BS2" microcontroller. So I'm using this now. And he borrowed a book for me: "physical Computing" by Dan O'Sulivan and Tom Igoe "Sensing and Controlling the Physical World With Computers"

http://parallax.com http://www.tigoe.net http://www.tigoe.net/blog ... the link's just for interest ...

how ever I followed all the instructions that you gave me with the command line, and got no result, I've tried all kynds off it command line, command prompt from start menu, and did'nt find a one wich wuld prompt like: C:> ore: C:\Windows> . Myne whas prompting like: C:\Documents and Settings\user name.computer name>_

and I allso pasted the full line in one row: C:\Program Files\arduino-0011-win\arduino-0011\hardware\tools\avr\bin\avrdude -CC:\Program Files\arduino-0011-win\arduino-0011\hardware\tools\avr\etc\avrdude.conf -v -v -v -v -pm8 -cdapa -e -Ulock:w:0xFF:m -Uhfuse:w:0xca:m -Ulfuse:w:0xdf:m -F -b115200 and still the same, I got messages about an adress not found or a unrecognised program ore a batch file...

huh... but wait! I seem to have the same problem with my new toy "BS2" in the "BASIC" software, it ses "No BASIC Stamps found".

here I'm using the serial cable insted of a parallel as with arduino, I think there's something wrong with the ports of my computer... do have to reinslall my windows may be ?

please help enny one, I have only 3 heares left on my head :-)

I allso posted to parallax.com forumes:

http://forums.parallax.com/forums/default.aspx?m=283497&f=5&p=1#m283497