Upload Problem to mega644p

Hi all and - sorry for this generalistic problem description -

Im working for hours to get this 644(P-PU) to "life" but it wont "speak" to me. The breakout board is more or less the approach from Sanguino. I have some troubles with those 6 input pins because my arduino self-build (with RS232) only uses 4 pins (txd,rxd,dtr,signalGnd) . So im actually using the arduino ide(1.0.5) with the Sanguino expansion(bootloader,boards,usw) a extern USB 2 RS232 converter and a usbasp for bootloader burning. This conifguration works fine with for the Arduino, but lacks in serial communication with the Sanguino. Burning the bootloader for the 644 with the usbasp was no problem but uploading a sketch ends in - not in sync 0x00 - Atm i use the vcc from the usbasp and have RxD,TxD,Signalmass,CTS,RTS connected to the board (so the vcc pin is nc, but shouldnt be a problem) and still no conncetion.

Has anyone a clue why the upload isnt possible ?

Thanks for Help ! Mosfett

Solved it !

The Problem was that the Arduino works with the RS232 interface but the
Sanguino needs TTL CMOS communication.
Now im converting via two MAX232 the incoming and outgoing serial
communication and everything works fine.