Upload problem with motor shield

I purchased a motor shield on the internet which looks identical to the ladyada design, but without the ladyada name on it. When I use the shield on top of my freeduino board (duemillanove compatible), I always fail to upload my sketch over the serial interface. I keep getting the [color=#ff0000]avrdude: stk500_recv(): programmer is not responding[/color] error message. I also tried pressing reset before upload etc.. When I remove the motor shield, upload works fine and the shield thereafter works as expected... I checked the pins 0 and 1, they are not connected on the motor shield. However, something else seems to disrupt the serial connection. I am running board and shield with an external power supply which is capable of 1A, so I would not expect this to be a power problem. Any Ideas what could cause this failure?

Without more information about the shield you are using, it is going to be hard to troubleshoot what the problem is.

I finally found the original web page of the ebay seller. This is the shield they send me: http://www.emartee.com/product/41468/Arduino-Motor-Drive-Shield

It's layout looks equivalent to the ladyada board layout (from my visual inspection and comparing with the eagle brd file)

Meanwhile I checked the board. For test purpose I removed the L293D and 74HC595 chips, still no change in behavior. It seems like there's something wrong with the plain PCB. If I just knew where to look. There's no obvious error like cold soldering connections or short circuit due to solder balls.

I checked the pins 0 and 1, they are not connected on the motor shield.

Checked for continuity with a DMM?

Can you Tx/Rx to/from the serial monitor once running?

If not write a loop that does nothing but Serial.print(0xAA) and start tracing things with a scope.


Rob