Upload problem

Hi,

I’m using a premade Arduino Board with an ATMEGA 168 inside.
I used it for a while now, and uploading was never a problem.

Now I started building my project, and everything went, fine, even the uploading.
now after NO CHANGES, I can’t upload anymore.

The arduino software tool says it uploads fine, but the old program, that was uploaded weeks ago is still in use.

How can this be solved? Is there a way of rebooting it?

Do you have ATmega168 selected in the Tools > Microcontroller menu?

I never changed that.
My MCU is still on atmega168 under the Tools section.
Also my serial Port is Com16 which is my USB port.
I checked on Device manager.

I also press the reset button in time.

The meesage when uploading is :

Done uploading.

Atmel AVR ATmega 168 is found.
Uploading: flash
Firmware Version: 1.15
Firmware Version: 1.15

hey

what do you have connected to the Arduino’s pins… anything on the RX or TX pins?

D

RX is connected to the ground, else the battery won’t work. I saw the fix on this forum.

I also tried to upload without connecting the RX to the ground. That didn’t worked either.
The TX is not in use.

hi

do you mean connected to ground through a 10K resistor? that’s the proper way.
What else do you have connected?
D

Yes with a 10k resistor.

From 13 to 2 there are LED’s connected , to the ground.
On input 0 there is a pressure sensor, who is also connected to the ground and the 5V power source.
There is a 9V battery on the X1

that’s all.

hey

does upload work if you disconnect everything except the USB jack, and then power it via USB?

D

Hmm that’s gonna be hard. It’s already build inside a sweater. I’ll give it a shot…
I’ll let you know if it worked.

I’m thinking it is one of two things:

  • RX resistor needs to be lower value ( 1K perhaps), or
  • there is a short somewhere that is influencing the power supply or the upload process…

You could try

  • changing the RX resistor to 1K, or
    -disconnecting everything except the pin 13 led, and then powering it by USB to test if it will upload properly

D

That didn’t work.

disconnecting everything except the pin 13 led and usb power didn’t work?

D

only the leds, so 13-2 are still connected. I will try tomorrow. Everything soldered, so it’s hard to get it out.

I disconnected ALL the things now. I uploaded. And still the old program is in memory…

ah-- well then you have a software problem, either in your machine, or in the bootloader. Bootloaders do not often go wrong, so I would reinstall your Arduino software and start from scratch.

D

how exactly do you do that?
And can the problem be caused by overloading the voltage? I might had some shortcircuit for a few seconds

sure, the board could be broken from a short circuit, but it would have to be a long one! The regulator shuts down on a short circuit. Board don’t burn out very often. When you plug in an LED ot pin 13, does it blink rapidly when you press the reset button?

D

I have a similar problem. I have changed nothing but the circuit with the Arduino Mini and ther USB to Serial is not working anymore since yesterday. It was working for about a month with daily use.

Pin 13 LED is blinking fast now.
Upload is only possible when i disconnect the board, connect again and then hit upload.
RX and TX are not blinking while working.

Things that may have occured:
New security patch for windows this morning.
Maybe a ESD-event (high power due to electrostatic charge)

well, I now have this issue.
everything disconnected except led on pin 13.
I get a a flashing led on reset.
upload takes place without error, but if I plug stuff back in, it’s still running an old sketch.
I’m trying to upload the blink sketch so that the only thing connected is usb and led on pin 13…

If it helps, I did have this on battery yesterday and experienced some odd behavior with sketches not resetting while usb was plugged-in… I don’t really know what was going on as I never really made any strong correlations, but while on battery it seemed a little weird, but I didn’t have the RX connected to ground

Any ideas? there wasn’t any followup/explanation to the previous messages.
Thanks,
Chris

I’m not really sure what’s happening. I think it might have something to do with a noisy power supply - the NG’s didn’t have brownout detection enabled, and it’s possible the chip got into a weird state when the power supply voltage dropped. You might need to reburn the bootloader onto the chip (or just a buy a chip that has the bootloader on it).