Upload program to Arduino Uno R3 from cmd

Hi I have seen this topic many times but all mentioned solutions still doesn't work for me. I have to upload program to Arduino Uno R3 via Command Window. I have installed Arduino software v1.0.6. I can write compile and UPLOAD a sketch from Arduino IDE without any problems.

Now I try to do the compilation and uploading process from my software and I stuck with upload. I found I tried this sequence:

avrdude -V -F -C avrdude.conf -p atmega328p -c stk500v1 -P com16 -b 57600 -U flash:w:myarduino_blink.hex -vvvv

but I only got this:

avrdude: Version 5.11, compiled on Sep  2 2011 at 19:38:36 
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/ 
         Copyright (c) 2007-2009 Joerg Wunsch 

         System wide configuration file is "c:/Programy/Arduino/hardware/tools/avr/etc/avrdude.conf" 

         Using Port                    : com16 
         Using Programmer              : stk500v1 
         Overriding Baud Rate          : 57600 
avrdude: Send: 0 [30]   [20]  
avrdude: Send: 0 [30]   [20]  
avrdude: Send: 0 [30]   [20]  
avrdude: Recv:  
avrdude: stk500_getsync(): not in sync: resp=0x00 

avrdude done.  Thank you.

I've tried all possible baude rates, not only this one. Arduino Uno is new, out-of-the-box. When I try this command an RX led is blinking 3-4 times but nothing else. Anybody has an idea what to do with this?

Try this:

avrdude -C ..\etc\avrdude.conf -p atmega328p -c stk500v1 -P \.\com16 -U flash:w:myarduino_blink.hex -vvvv

If that doesn't work, try stk500v2, and so on. Chances you're using the wrong programmer.

Note: Just to keep on the safe side, do not use -F or -V.

AlxDroidDev: If that doesn't work, try stk500v2, and so on.

Also try "arduino" instead of "stk500v1".

Thanks for tips!! This combination works perfectly:

avrdude -C avrdude.conf -p atmega328p -c arduino -b 115200 -P com16 -U flash:w:myarduino_blink.hex