upload responds with "Programmer is not Responding"

This seems to be a common problem without a common solution. I have found none that work yet. Here are my particulars. Thanks in advance for any help. This seems to be a Mac issue as the Uno displayed the error message straight out of the quality sealed box.

MacBook Pro OSX 5.10.8

History Ran Duemilanove (sealed package from sparkfun.com) for several months on Mac and rev 0019. In early April upgraded to 0022 with no problems or changes. Out of the blue, this error message started appearing after program edit upload: Binary sketch size: 1008 bytes (of a 30720 byte maximum) avrdude: stk500_recv(): programmer is not responding avrdude: stk500_recv(): programmer is not responding

• Re-installed both Arduino 0019 and 0022 multiple times (both have worked in the past, both have same error message now) • Reinstalled FTDI USB Serial Driver 10 4 10 5 10 6 several times (same driver for both 0019 and 0022.) • Used both Duemilanove (sparkfun.com) and new UNO (RobotShop.com). UNO demonstrated the error message straight out of the sealed box w/o any other connections other than USB. • Used different USB cables • Used standard issue “Blink” as test sketch • Used all 3 USB ports on MAC • Tried holding Arduino reset while connecting USB cable • Tried holding Arduino reset while initiating upload, releasing reset after various delays • Reset MAC PRAM by starting up MAC with “option” + “command” + “R” + “P” for 3 startup tones • Tried running UNO on windows PC – had different error messages below (the setup of driver never completed due to inflexable XP driver wizard - Uno showed in Device Manager COM port, Duemilanove would not, nice to have XP run to verify that these boards are OK, but I really don't want Windows XP going forward anyway) Binary sketch size: 1018 bytes (of a 32256 byte maximum) avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51 • Opening Mac System Profiler / Hardware / USB = “FT232RUSB UART” when a port is connected to the Duemilanove, and = “Arduino Uno” when the UNO is connected. Status report: Arduino Uno: Product ID: 0x0001 Vendor ID: 0x2341 Version: 0.00 Serial Number: 6493234383835131D141 Speed: Up to 12 Mb/sec Manufacturer: Arduino (www.arduino.cc) Location ID: 0x3a200000 Current Available (mA): 500 Current Required (mA): 100

• LEDs on power up: UNO => PWR green ON, flickering yellow L, then steady state flashing yellow L (1 sec on, 1 sec off) even without Blink sketch loaded • LEDs on power up: Duemilanove => PWR green ON and flickering yellow TX, then TX off. • LEDs during upload: UNO => PWR green ON, steady state flashing yellow (no new activity or change) • LEDs during upload: Duemilanove => PWR green ON but no activity.

• From OSX terminal window; sudo dmesg => FTDIUSBSerialDriver: 0 4036001 start – ok

Ran Repair Disk Permissions on the HDs - no help

From terminal: ls /dev/usb /dev/cu.usbmodem1a21 /dev/tty.usbmodem1a21

From terminal: bzgrep FTDI /var/log/system.log* Long resulting list so this a part of listing => /var/log/system.log:Apr 27 12:29:06 mypc kernel[0]: FTDIUSBSerialDriver: 0 4036001 start - ok /var/log/system.log:Apr 27 20:26:48 mypc kernel[0]: Finder[121] Unable to clear quarantine `FTDIUSBSerialDriver_10_4_10_5_10_6.mpkg': 30

Is 'quarantine' a problem? How to fix?

echo "[Extensions]" [Extensions]

for KEXT in ls -d /System/Library/Extensions/*FTDI* ; do

echo $KEXT find "$KEXT" -name InfoPlist.strings -exec cat {} \; done /System/Library/Extensions/FTDIUSBSerialDriver.kext ??/* Localized versions of Info.plist keys */ CFBundleName = "FTDIUSBSerialDriver"; CFBundleShortVersionString = "2.2.14"; CFBundleGetInfoString = "2.2.14, Copyright (c) 2005-2009 FTDI Ltd."; NSHumanReadableCopyright = "Copyright (c) 2005-2009 FTDI Ltd.";

echo "[Devices]" [Devices]

echo "[System logs]" [System logs]

I had this error and quickly fixed it. For some reason the serial port selection changed to /dev/ttyS0 I changed it back to /dev/ttyUSB0 by going to Tools - Serial Port then selecting the right comm port.

I was using 0022 and it happened after I uploaded a 7k sketch realized I made an error corrected (2 lines) then upload again . . . error

Hope this helps :)