Upload script to arduino nano using High Sierra on MacBook pro

I am new to the arduino /electronics world, I know nothing.
I cannot get the IDE to see the arduino nano!
It does not appear in the port options. I have tried replacing the USB and Arduino nano board with the same result. The USB port on the MacBook pro can read and write to my USB flash drive.
I am using High Sierra.
I have been able to upload the same script to an Arduino UNO.
The local computer repair man spent an hour trying to solve the problem!!!
I have tried both original and copies of the arduino nano boards and two different min iUSB cables.
Is there anyone out there who has actually used High Sierra to up load to a arduino nano??
Any help appreciated.

If you expect the Nano to show in the ports under the name Nano, that will never happen; Nanos don't identify themselves as Nanos.

If it's not one of the ports that you show, it's a driver issue. What does your operating think about it? The original Nanos use the FTDI TTL-to-USB converter, most clones use the CH340 TTL-to-USB converter.

If it's one of the ports that you show, try the different options under Tools -> Processor.

Thanks, I needed to run the ,,,sudo nvram boot-args="kext-dev-mode=1"....Terminal command in the Utilities so it could see the driver. Thanks..

1 Like

Thanks for the follow up.

If your issue is solved, you can click the Solution checkbox under the most useful reply. That way others who encounter the same problem know that it is solved / a solution was provided.

Enjoythe Arduino world.