Upload to Arduino Leonardo freezes my Windows 8 computer

Hello,

Every time I try to program my Arduino Leonardo the Windows 8 freezes and I have to hard reboot by pressing the power button.

The mouse cursor keeps blinking inside Arduino IDE, but neither the mouse/trackpad nor keyboard works anymore.

I have the Arduino Leonardo driver installed (see attachment).

How can I fix this?

Versão do driver: 1.0.0.0

...is very suspicious. Mine is...

Driver version: 5.1.2600.0

Clicking Driver Details reveals this...

File version: 6.1.7601.17514

In the years that I have worked with Microsoft products they have always set the major / minor version to match the internal product version number. For example, I'm writing this post from a Windows 7 computer. usbser.sys (the kernel driver responsible for Leonardo communcations) is stamped with version 6.1.7601.17514. The product version (the internal version number of Windows 7) is also 6.1.7601.17514.

With a version of 1.0.0.0 I can imagine two possibilities...

  1. With Windows 8, Microsoft restarted numbering from 1. In my opinion, this is highly unlikely.

  2. The company that sold you the computer included their own version of usbser.sys.

Were I in your shoes, I would check the hardware vendor's website for driver updates.

Thanks for answering!

My computer is a Dell Inspiron notebook and I've installed all driver updates they told me to do. But the driver version hasn't changed (that screenshot remains the same) and the machine keeps freezing.

When I use a VMWare virtual machine with Ubuntu 13.04 it works fine (I can program the board).

What should I do?

What version number is displayed from Driver Details?

Sorry for the delay. The file version is "6.2.9200.16384" (see attachment).

But the driver version remains unchanged (like the last attachment).

Versão do driver: 1.0.0.0

...is apparently correct for Windows 8. I'll check the version of usbser.sys in a few minutes...

6.2.9200.16384

...same driver.

Same driver and my Micro works flawlessly so back to the original post...

pauloborges:
Every time I try to program my Arduino Leonardo the Windows 8 freezes and I have to hard reboot by pressing the power button.

The mouse cursor keeps blinking inside Arduino IDE, but neither the mouse/trackpad nor keyboard works anymore.

Anything connected to the Leonardo?

Anything connected to the Leonardo?

Nope. Only the Leonardo.

I've been doing some tests: the board works OK in another computer with Windows 7 and in another computer with Ubuntu 13.04 (two different computers).

I'll try to make a dual-boot in the first computer (the one with Windows 8 ) with Ubuntu 13.04 to test my USB ports (just for sanity test, because it was working OK before). Very soon I'll post the results.

I managed to program the Leonardo in the first machine using Ubuntu 13.04. But I can't make a proper dual-boot because of UEFI/Secure boot/Windows 8 way of handle these things.

But know we can confirm that the problem isn't the USB plug.

I'll try to restore the Windows 8 using recovery disks.

Even after restoring the disk it keeps freezing.

Initially I thought the problem had stopped. But after programming the board couple of times the problem returned. The computer also freezes when I unplug the Leonardo board.

I'm stumped. I can't even think of anything to suggest for a Hail Mary.

Thank you for trying to solve the problem. Unfortunately I still don't have a solution. :frowning:

Meanwhile I'll use another computer.

Hello,

I have the exact same problem with the same computer (Dell Inspiron Notebook) the same board (Leonardo) the same Windows. If you found out a solutions please let me know!!

Thanks!