Upload von Uno R3 an Mac OSX funktioniert nicht - not in sync

Hallo,
ich versuche nun seit Tagen dieses Problem zu lösen, habe aber keine Idee mehr wie ich weiter vorgehe.

Ich möchte einen Arduino R3 an einem Mac mit OSX 10.15 Catalina mit der Ardino IDE 1.8.10 (und 1.8.13) programmieren. Ich nehme zB den Blink Code. Am Arduino ist kein Bauteil angesteckt. Jedesmal erscheint der Sync Fehler beim Aufruf von AVRDude

Globale Variablen verwenden 9 Bytes (0%) des dynamischen Speichers, 2039 Bytes für lokale Variablen verbleiben. Das Maximum sind 2048 Bytes.
/Applications/Arduino-3.app/Contents/Java/hardware/tools/avr/bin/avrdude -C/Applications/Arduino-3.app/Contents/Java/hardware/tools/avr/etc/avrdude.conf -v -patmega328p -carduino -P/dev/cu.usbmodem6201 -b115200 -D -Uflash:w:/var/folders/qk/200_rgcx6k9646l522wgxn5r0000gn/T/arduino_build_111408/sketch_jan31a.ino.hex:i 

avrdude: Version 6.3-20190619
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "/Applications/Arduino-3.app/Contents/Java/hardware/tools/avr/etc/avrdude.conf"
         User configuration file is "/Users/bastianlinge/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/cu.usbmodem6201
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x54
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x65
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x73
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x74
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x21
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x20
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x54
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x65
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x73
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x74

avrdude done.  Thank you.

Beim Hochladen des Sketches ist ein Fehler aufgetreten

Den Loopback Test habe ich gemacht, es kommt was zurück, aber nicht die selben Buchstaben die ich im Serial Monitor sende.

Ich kann auf diesen Uno den Blink Code mit einem alten XP Laptop hochladen. Da habe ich den Code erweitert, so dass der Uno immer ein Wort auf dem Serial Port ausgibt. Stecke ich den Uno dann am Mac an, zeigt mir der SerialMonitor dieses Wort an.

Der Uno wird am Mac richtig erkannt, /dev/cu.usbmodem6201

Ich kann auch die Seriennummer des Uno auslesen über den Mac.

An diesem Mac kann ich ESP8266 und ESP32CAM auch ohne Probleme programmieren, aber die haben einen CH340 Chip.

Auf einen Leonardo lässt sich auch kein Code hochladen, dort sieht die Fehlermeldung aber anders aus:

Uploading using selected port: /dev/cu.usbmodem4301


/Users/USER/Library/Arduino15/packages/arduino/tools/avrdude/6.3.0-arduino17/bin/avrdude -C/Users/USER/Library/Arduino15/packages/arduino/tools/avrdude/6.3.0-arduino17/etc/avrdude.conf -v -patmega32u4 -cavr109 -P/dev/cu.usbmodem4301 -b57600 -D -Uflash:w:/var/folders/qk/200_rgcx6k9646l522wgxn5r0000gn/T/arduino_build_13575/Blink.ino.hex:i 





avrdude: Version 6.3-20190619


         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/


         Copyright (c) 2007-2014 Joerg Wunsch





         System wide configuration file is "/Users/USER/Library/Arduino15/packages/arduino/tools/avrdude/6.3.0-arduino17/etc/avrdude.conf"


         User configuration file is "/Users/USER/.avrduderc"


         User configuration file does not exist or is not a regular file, skipping





         Using Port                    : /dev/cu.usbmodem4301


         Using Programmer              : avr109


         Overriding Baud Rate          : 57600


         AVR Part                      : ATmega32U4


         Chip Erase delay              : 9000 us


         PAGEL                         : PD7


         BS2                           : PA0


         RESET disposition             : dedicated


         RETRY pulse                   : SCK


         serial program mode           : yes


         parallel program mode         : yes


         Timeout                       : 200


         StabDelay                     : 100


         CmdexeDelay                   : 25


         SyncLoops                     : 32


         ByteDelay                     : 0


         PollIndex                     : 3


         PollValue                     : 0x53


         Memory Detail                 :





                                  Block Poll               Page                       Polled


           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack


           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------


           eeprom        65    20     4    0 no       1024    4      0  9000  9000 0x00 0x00


           flash         65     6   128    0 yes     32768  128    256  4500  4500 0x00 0x00


           lfuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00


           hfuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00


           efuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00


           lock           0     0     0    0 no          1    0      0  9000  9000 0x00 0x00


           calibration    0     0     0    0 no          1    0      0     0     0 0x00 0x00


           signature      0     0     0    0 no          3    0      0     0     0 0x00 0x00





         Programmer Type : butterfly


         Description     : Atmel AppNote AVR109 Boot Loader





Connecting to programmer: .


YSY???"; type = S Id = "


.Y; Hardware Version = S.Y


avrdude: error: buffered memory access not supported. Maybe it isn't


a butterfly/AVR109 but a AVR910 device?


avrdude: initialization failed, rc=-1


         Double check connections and try again, or use -F to override


         this check.





avrdude: error: programmer did not respond to command: leave prog mode

Ich weiss nicht wie ich da jetzt weiter vorgehen soll.

Bin für jeden Tipp Dankbar!

Gruss!

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.